fork failed

Asked by Jeff Squyres on 2021-01-06

I am trying to fork so that I can submit a pull request against it.

I click the "fork it directly to your account" link, confirm that the "Fork it to the following owner" is my user, and then click the "Fork it" button. The subsequent page tells me "Repository forked" and a separate notice "The repository is being created".

I've waited quite a while (half an hour?), and even tried repeating this process a few times, but the fork never seems to get created.

If I try to navigate to it in my browser, I'm told it's a 404, and if I try to git push to the URL it said I would be able to git push to, it fails with:

$ git push git+ssh://<email address hidden>/~jsquyres-cisco/ubuntu/+source/shim pr/better-make-cert-field-values:pr-better-make-cert-field-values
fatal: remote error: Could not create repository: [Errno 13] Permission denied

Do I need to do something special to fork this repo?

Thank you!

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Jeff Squyres
Last query:
Last reply:

Hi, Jeff.

This seems to be similar to the problem we faced a few months back, reported at

We will take a look internally and get back to you.

Jeff Squyres (jsquyres-cisco) said : #2

Thank you!

Hi, Jeff!

We have applied the fix for that, and I was able to fork that repository to my account (

Could you please try forking it now?

Jeff Squyres (jsquyres-cisco) said : #4

It worked -- thank you!