PPA build dependency (atk-bridge-2.0) not installed

Asked by Nalin.x.Linux on 2020-10-17

Hello team, I have included libatk-bridge2.0-dev in debian/control file.
But I got following error.

Build log :

checking for ATSPI2... yes
checking for ATKBRIDGE... no
configure: error: Package requirements (atk-bridge-2.0 >= 2.26) were not met:

Package 'atk', required by 'atk-bridge-2.0', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Complete build log : https://launchpadlibrarian.net/502412298/buildlog_ubuntu-focal-amd64.orca_3.36.1-0ubuntu2_BUILDING.txt.gz

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Nalin.x.Linux
Solved:
2020-10-18
Last query:
2020-10-18
Last reply:
2020-10-17
Manfred Hampl (m-hampl) said : #1

Just a guess:

Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
Package 'atk', required by 'atk-bridge-2.0', not found

My interpretation of that message: 'atk-bridge-2.0' was correctly found, but that depends on atk, which is not found

The file atk.pc is contained in the package libatk1.0-dev. Try adding that one.

Colin Watson (cjwatson) said : #2

If it's as Manfred suggests (which seems likely), then that would be a bug in libatk-bridge2.0-dev for not having an appropriate dependency. But in any case Launchpad can't control that sort of thing - all it can do is install the build-dependencies you asked for, which in this case it has done.

Nalin.x.Linux (nalin-x-linux) said : #3

Simply added libatk1.0-dev to build dependency and it worked. Thanks a lot.