package failed to upload: Archive is too short

Asked by Andrea Righi on 2020-09-09

I'm trying to build the latest hwe 5.8 kernel in a ppa, but the upload is failing with the error: "Archive is too short".

I've tried to compile the packages manually on a local build host and apparently they are all fine (they can be extracted without any problem).

I can reproduce this problem both in my hwe-5.8 ppa and in the canonical-kernel-team/bootstrap ppa.

This is my ppa:
https://launchpad.net/~arighi/+archive/ubuntu/hwe-5.8/

And here is a link to the build that is failing:
https://launchpad.net/~arighi/+archive/ubuntu/hwe-5.8/+build/19924097

Can you help me to understand why this build/upload is failing? Thanks in advance.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2020-09-09
Last reply:
2020-09-10
Manfred Hampl (m-hampl) said : #1

Attempt to identify the cause:
From the buildlog:

dh_builddeb -plinux-image-unsigned-5.8.0-18-generic-dbgsym
INFO: pkgstriptranslations version 144
INFO: Disabling pkgstriptranslations for PPA build
INFO: Disabling pkgmaintainermangler for PPA build
INFO: Disabling pkgstripfiles for PPA build
dpkg-deb: building package 'linux-image-unsigned-5.8.0-18-generic-dbgsym' in '../linux-image-unsigned-5.8.0-18-generic-dbgsym_5.8.0-18.19~20.04.3_amd64.deb'.
dpkg-deb: error: cannot append ar member file (data.tar.xz) to '../linux-image-unsigned-5.8.0-18-generic-dbgsym_5.8.0-18.19~20.04.3_amd64.deb': failed to write (No space left on device)
dh_builddeb.pkgbinarymangler: error: dpkg-deb --build debian/linux-image-unsigned-5.8.0-18-generic-dbgsym .. returned exit code 2
dh_builddeb.pkgbinarymangler: error: Aborting due to earlier error

Ioana Lasc (ilasc) said : #2

Hi Andrea

Upload timing for this build coincides with a network outage we've resolved. Wondering have you retried since the last attempt ?

Andrea Righi (arighi) said : #3

Hi Ioana, I restarted the build this morning (about 4 hours ago) in a different ppa (ppa:canonical-kernel-team/bootstrap), but I'm still getting the same error:

https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/bootstrap/+build/19913002

Colin Watson (cjwatson) said : #4

Andrea, have you looked into the "No space left on device" observation that Manfred made? That looks like the important bit: it very much looks as though your build ran out of disk space but that some part of the packaging toolchain, probably pkgbinarymangler (which is its own package in Ubuntu, not something controlled by Launchpad) failed to propagate the error code correctly and so the error wasn't noticed until much later.

Manfred Hampl (m-hampl) said : #5

see Bug #1894607
Andy Whitcroft hit the same problem.

Can you help with this problem?

Provide an answer of your own, or ask Andrea Righi for more information if necessary.

To post a message you must log in.