why launchpad can't import my public key?

Asked by hosxy

I have been upload my public key to keyserver.ubuntu.com several hours ago,and I can also find my public key on it by search my email or name.
I use
         gpg --keyserver keyserver.ubuntu.com --search-keys hosxy
also can find my key
but launchpad always show can't import my public key, what should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Thiago F. Pappacena
Solved:
Last query:
Last reply:
Revision history for this message
Bruce Wayne (bw35) said :
#1

i also have the same problem

Revision history for this message
Best Thiago F. Pappacena (pappacena) said :
#2

Hi, hosxy.

do you know what what kind of algorithm did you select when generating you GPG key?

Launchpad is currently not compatible with GPG v2 algorithms, as documented in https://bugs.launchpad.net/launchpad/+bug/1827369 and https://answers.launchpad.net/launchpad/+question/690290.

Could you please try uploading a GPG v1 compatible key?

Revision history for this message
hosxy (hosxy) said :
#3

Thanks Thiago F. Pappacena, that solved my question.