Please fix setuptools-scm - 3.1.0-1ppa1~bionic from PPAs

Asked by Kenneth Loafman on 2020-05-10

I screwed up and deleted setuptools-scm - 3.1.0-1ppa1~bionic from duplicity-develop-git and duplicity-release-git PPA archives. It won't go away after 24 hours. I need to delete it from both archives and delete it from the dput queue so I can replace it to build the bionic release of duplicity. I don't have the permissions to do so.

...Thanks,
...Ken

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2020-05-10
Last query:
2020-05-10
Last reply:
2020-05-10
Colin Watson (cjwatson) said : #1

You can never reupload the same version with different contents - it doesn't matter how long you wait. But are you in fact just trying to undelete it - that is, restore exactly what was there before you accidentally deleted it?

Just undelete it if possible.

...Thanks,
...Ken

Best Colin Watson (cjwatson) said : #3

On each PPA, go to "View package details" → "Copy packages"; enter "setuptools-scm" as the package name, select "Any status", and press Filter; select the source to undelete; select the same PPA under "Destination PPA" (i.e. you're copying it back into itself); leave "Destination series" as "The same series"; select "Copy existing binaries"; and press "Copy Packages".

Thanks for the quick responses. I would have never tried that.

...Ken

Thanks Colin Watson, that solved my question.