GPG Key Import failing

Asked by Kelly Trinh on 2020-04-28

Registering my GPG key with fingreprint AF8E 92AA 57F8 971E 6887 B4BE A805 EA97 7B7B F929

IT is on the ubuntu keyserver (since 31 Mar 2020 - so well past any initial keyserver sync period) and verified by searching on the keyserver web interface

After entering fingerprint to page "Change your OpenPGP keys" get standard error message:

Launchpad could not import your OpenPGP key
Did you enter your complete fingerprint correctly? (Help with fingerprints)
Is your key in the Ubuntu keyserver yet? You may have to wait between ten minutes (if you pushed directly to the Ubuntu key server) and one hour (if you pushed your key to another server). (Help with publishing keys)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Thiago F. Pappacena
Solved:
2020-04-28
Last query:
2020-04-28
Last reply:
2020-04-28

Hi, Kelly.

Are you using gpg2 to generate your key? Launchpad is currently only compatible with GPG v1 keys (https://bugs.launchpad.net/launchpad/+bug/1827369).

Could you please generate another key using a GPGv1-compatible type (like RSA)?

Kelly Trinh (kellytrinh) said : #2

The key was created by a 3rd party utility and I've adopted it for all applications now.

Indeed looks like it is a eddsa263 type key so if Launchpad only supports RSA then that is the cause of the problem (altho the error message could have been a lot clearer in this respect).

Will make as solved given this is known issue and fixes would be on documentation (until support forteh GPGv2 is added)

Kelly Trinh (kellytrinh) said : #3

Thanks Thiago F. Pappacena, that solved my question.