Git import failing (bzr-git exceptions.AssertionError)

Asked by Leonardo Robol on 2020-04-14

Dear all,
I have the repository at https://code.launchpad.net/~leo.robol/mpsolve/master set up to track https://github.com/robol/MPSolve; this worked up to a certain point, but the import is now failing with the log attached at the bottom (just one example).

May you have a look at what's going on? It appears to be a bzr-git problem: if I try to run bzr branch git://github.com/robol/MPSolve on my machine it gives essentially the same error.

Thanks!

Here is the traceback from the importer:

Traceback (most recent call last):
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/scripts/code-import-worker.py", line 106, in <module>
    sys.exit(script.main())
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/scripts/code-import-worker.py", line 101, in main
    return import_worker.run()
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/lib/lp/codehosting/codeimport/worker.py", line 554, in run
    return self._doImport()
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/lib/lp/codehosting/codeimport/worker.py", line 757, in _doImport
    inter_branch.fetch(limit=revision_limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/branch.py", line 722, in fetch
    self.fetch_objects(stop_revision, fetch_tags=fetch_tags, limit=limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/branch.py", line 745, in fetch_objects
    determine_wants, self.source.mapping, limit=limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/fetch.py", line 715, in fetch_objects
    progress=lambda text: report_git_progress(pb, text))
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/remote.py", line 461, in fetch_objects
    lambda x: os.write(fd, x), progress)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/remote.py", line 451, in fetch_pack
    pack_data, progress)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/remote.py", line 270, in fetch_pack
    graph_walker, pack_data, progress)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/env/local/lib/python2.7/site-packages/dulwich/client.py", line 1413, in fetch_pack
    lambda: False)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/env/local/lib/python2.7/site-packages/dulwich/client.py", line 558, in _handle_upload_pack_head
    have = next(graph_walker)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/env/local/lib/python2.7/site-packages/dulwich/object_store.py", line 1173, in next
    ps = self.get_parents(ret)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/fetch.py", line 708, in <lambda>
    lambda sha: store[sha].parents)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/object_store.py", line 674, in __getitem__
    _check_expected_sha(sha, commit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-2e26c9bbd21cdca248baaea29aeffb920afcc32a/bzrplugins/git/object_store.py", line 155, in _check_expected_sha
    expected_sha))
AssertionError: Invalid sha for <Commit 1a0308f5cc5f5b10707da1b0644de39ad42e05ae>: 6ecea8037d36375e90dbecdb76ca48fac1136cf1
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2020-04-14
Last reply:
2020-04-16
Tom Wardill (twom) said : #1

Hi,

This is a known bug awaiting upstream work so we can move Launchpad to Breezy rather than Bazaar.
Unfortunately, there's no direct fix for it.

However, given that it is a git original source, if you are happy importing it to a git repo rather than a bzr one, that should work.

Thanks,
Tom

Can you help with this problem?

Provide an answer of your own, or ask Leonardo Robol for more information if necessary.

To post a message you must log in.