Can you assign me as maintainer for launchpad.net/systemd

Asked by Dan Streetman on 2020-03-22

I do a bit of work for systemd in Ubuntu and I'd like to take this page over so I can get the daily git repo sync'ing working, and use lp build recipes to build daily using the upstream code.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Dan Streetman
Solved:
2020-03-25
Last query:
2020-03-25
Last reply:
2020-03-25
Tom Wardill (twom) said : #1

Hi,
We'd prefer not to assign something as important as systemd to a single person, as it creates a single point of failure that would require more intervention to recover from.
However we can do a couple of things:
1. If you can create a team, we'd be happy to assign the relevant permissions to the team, ideally with a couple of members.
2. If you can tell us what you want to achieve with the code imports, we might be able to fix that specifically, as creating recipes doesn't require being a project owner.

Thanks!

Dan Streetman (ddstreet) said : #2

I don't really need ownership of it, all I really was hoping to do was get the git repo syncing working again, e.g. like the old bzr repo used to be set up to sync:
https://code.launchpad.net/~registry/systemd/master

however, that's disabled since it started failing sync. Additionally, I'd prefer if it synced as a normal git repo, not a bzr repo. If you can set that sync up for a git repo, I can use it for recipies, etc elsewhere without needing any permissions for the main systemd project in lp.

Tom Wardill (twom) said : #3

Hi,
I've configured the systemd project to do a git-git import from https://github.com/systemd/systemd
Hopefully that puts you in a place you can proceed, once the import has completed.

Thanks

Dan Streetman (ddstreet) said : #4

Thanks! That should be all I need.

However, it seems the import is failing, with some errors "pre-receive hook declined", is that something fixable?

http://launchpadlibrarian.net/470506969/registry-systemd-+git-systemd.log

Tom Wardill (twom) said : #5

Looking at the code page for lp/systemd, it looks like an import has eventually succeeded.
Hopefully that's enough to unblock you for now?

I've created a bug at https://bugs.launchpad.net/turnip/+bug/1868935 to try and work out why the initial import failed.

Dan Streetman (ddstreet) said : #6

Yep, the import does appear to have worked, and does look like it's staying up to date, so the error seems to just be cosmetic, so as far as I'm concerned that should be all I needed.

Thanks!