Import failing for veusz

Asked by Jeremy Sanders

Hi -

The trunk for Veusz has moved to . I tried to add a new import for trunk-new, but this is now failing. Is it possible to replace the main trunk and fix the import?

Error message on import is:

2020-03-19 15:31:20 INFO Starting job.
2020-03-19 15:31:20 INFO Getting exising bzr branch from central store.
2020-03-19 15:31:21 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2020-03-19 15:31:21 INFO 35 bytes transferred
2020-03-19 15:31:22 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2020-03-19 15:31:24 INFO Importing branch.
2020-03-19 15:31:25 INFO
Traceback (most recent call last):
  File "/srv/", line 106, in <module>
  File "/srv/", line 101, in main
  File "/srv/", line 554, in run
    return self._doImport()
  File "/srv/", line 757, in _doImport
  File "/srv/", line 722, in fetch
    self.fetch_objects(stop_revision, fetch_tags=fetch_tags, limit=limit)
  File "/srv/", line 745, in fetch_objects
    determine_wants, self.source.mapping, limit=limit)
  File "/srv/", line 715, in fetch_objects
    progress=lambda text: report_git_progress(pb, text))
  File "/srv/", line 461, in fetch_objects
    lambda x: os.write(fd, x), progress)
  File "/srv/", line 451, in fetch_pack
    pack_data, progress)
  File "/srv/", line 270, in fetch_pack
    graph_walker, pack_data, progress)
  File "/srv/", line 1413, in fetch_pack
    lambda: False)
  File "/srv/", line 574, in _handle_upload_pack_head
    have = next(graph_walker)
  File "/srv/", line 1173, in next
    ps = self.get_parents(ret)
  File "/srv/", line 708, in <lambda>
    lambda sha: store[sha].parents)
  File "/srv/", line 674, in __getitem__
    _check_expected_sha(sha, commit)
  File "/srv/", line 155, in _check_expected_sha
AssertionError: Invalid sha for <Commit aaa8887df6c3e75841510981b3d7cf2325f80cb2>: 5a8afe878256ee96caba4c7ba317151ffa92b93f
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Tom Wardill (twom) said :

This is
There's unfortunately still no fix for this as there's no upstream release that we can use yet.
As soon as we're able, we'll get this fixed.

Given upstream has moved to git, changing the code import to use git-git (importing into a git repository rather than a bazaar one) would also fix the problem, if this is a usable solution for you.
If you don't use the translations from the existing import, then it should work.
It does, however, require you to recreate any recipes that you have.


Can you help with this problem?

Provide an answer of your own, or ask Jeremy Sanders for more information if necessary.

To post a message you must log in.