Launchpad cannot find packages when building a recipe

Asked by ckti on 2020-02-19

Hello:
  I am building a recipe https://code.launchpad.net/~ckti/+recipe/ckti-ion-recipes-daily which needs libdb-4.8-dev and libdb-4.8++-dev to compile. i keep getting the following error

The following packages have unmet dependencies:
 builddeps:ioncoin : Depends: libdb4.8-dev but it is not installable
                     Depends: libdb4.8++-dev but it is not installable
E: Unable to correct problems, you have held broken packages.
RUN: /usr/share/launchpad-buildd/bin/in-target scan-for-processes --backend=chroot --series=bionic --arch=amd64 RECIPEBRANCHBUILD-2503685

my /debian/control file looks like this

Source: ioncoin
Section: utils
Priority: optional
Maintainer: ckti.ion <email address hidden>
Build-Depends: debhelper (>=9),autotools-dev,dh-autoreconf,pkg-config,libdb4.8-dev,libdb4.8++-dev,libboost-all-dev,qt5-qmake,qt5-default,qtchooser,libssl-dev,qttools5-dev-tools,protobuf-compiler,libtool,automake,libevent-dev,bsdmainutils,libqrencode-dev,libminiupnpc-dev,libgmp-dev,software-properties-common,gcc-7,g++-7
Standards-Version: 3.9.7
Homepage: <http://ioncore.xyz>

Package: ioncoin
Architecture: i386 amd64 armhf arm64
Depends: ${shlibs:Depends}, ${misc:Depends} xdg-utils
Description: IonCoin Crypto Coin
 CLI and GUI Wallet for IonCoin Cryptocurrency

If i remove libdb/libdb++-4.8 from the dependencies the recipe works up until configure cannot find the libdb libraries

Can anyone shed any light on this?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-02-20
Last query:
2020-02-20
Last reply:
2020-02-19
Best Manfred Hampl (m-hampl) said : #1

The package libdb4.8-dev is obsolete. It has only existed in Ubuntu releases up to saucy (13.10), but has never existed for Ubuntu xenial and bionic.

You should investigate, whether you can use libdb5.3 instead.

see also https://bugs.launchpad.net/ubuntu/+source/db4.8/+bug/1263565

ckti (ckti) said : #2

Yeah we're trying to upgrade to 5.3 at some point but the build-deps will need some tweaking. Thanks for the info though...

ckti (ckti) said : #3

Thanks Manfred Hampl, that solved my question.

Manfred Hampl (m-hampl) said : #4

Just to avoid a potential misunderstanding of my answer.

You should try using the packages libdb5.3-dev instead of libdb4.8-dev and libdb5.3++-dev instead of libdb4.8++-dev in your build dependencies, not the package libdb5.3.

ckti (ckti) said : #5

yeah, i understood that....wil stick to regular ppaas and snapcraft for now

Peter J. Mello (roguescholar) said : #6

Another potential fix would be to copy the libdb4.8 source package from another PPA that has already built it for the series you need. For instance, I know the Bitcoin PPAs rely on that package, their Stable PPA can be found here: https://launchpad.net/~bitcoin/+archive/ubuntu/bitcoin

ckti (ckti) said : #7

yeah fair enough that woudl work for a ppa (have done it that way in the past) but for a launchpad recipe i couldn't find a way to import another ppa like regular launchpad does

Colin Watson (cjwatson) said : #8

You just configure it on the recipe's target PPA. Recipes don't have their own independent configuration for this sort of thing.

ckti (ckti) said : #9

Ahh...will have to give that a try, didn't know i could do that thank you :)