Error Message when enabling Livepatch : cannot parse /etc/fstab: expected between 3 and 6 fields, found 8

Asked by iglinux on 2020-01-21

Ubuntu 18.04
4.15.0-66-generic #75-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux

When enabling Livepatch from Canonical Livepatch Service, I followed the instructions and pasted the commands in terminal:

$sudo snap install canonical-livepatch

that was OK

$sudo canonical-livepatch enable ###my key number###

Returned:
system_key.go:120: cannot determine nfs usage in generateSystemKey: cannot parse /etc/fstab: expected between 3 and 6 fields, found 8

Any easy directions on that?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-01-21
Last query:
2020-01-21
Last reply:
2020-01-21
Manfred Hampl (m-hampl) said : #1

"cannot parse /etc/fstab: expected between 3 and 6 fields, found 8"

What is the output of

cat /etc/fstab

(you are free to obfuscate Information that you want to keep secret, as Long as the gist of the contents stays readable)

iglinux (iglezer) said : #2

Good call, here's the out put:

UUID=nnnfnnd-nncb-nenn-abaf-nnnnndnnnncd / ext4 defaults 0 0
/swap.img none swap sw 0 0
tmpfs /run/shm tmpfs defaults, noexec, nosuid 0 0 #edit note

Best Manfred Hampl (m-hampl) said : #3

I assume that the error is in the last line. There must not be space characters between the options.

edit the /etc/fstab file and change the last line into

tmpfs /run/shm tmpfs defaults,noexec,nosuid 0 0

Colin Watson (cjwatson) said : #4

The Canonical livepatch service isn't part of Launchpad. I think the right place to file bugs on the livepatch client is https://launchpad.net/canonical-livepatch-client.

Colin Watson (cjwatson) said : #5

(Having said that, Manfred is likely right - but I'd like to encourage filing things against the right project rather than against Launchpad itself.)

iglinux (iglezer) said : #6

Dear Manfred, I assume it worked, since I got the output:
Successfully enabled device. Using machine-token: <id>

Colin, I totally agree. Since the problem is solved I will let as it is, next time I will make sure to send it to livepatch.
Thank you.

iglinux (iglezer) said : #7

Thanks Manfred Hampl, that solved my question.