builds from gitlab CI don't show up on PPA

Asked by Lokesh Mandvekar on 2019-07-22

So, I run gitlab CI jobs for autobuilding deb packages for cri-o (and other tools). See a sample job: https://gitlab.com/lsm5/cri-o/-/jobs/256073966 . Though toward the end of the log it says that the build was successfully submitted, the build fails to show up on the PPA.

If I build it locally and submit it manually, it works as expected though.

On gitlab CI, I'm using the 'lsm5+bot' user and uploading via sftp, while on local machine I'm using user 'lsm5' and uploading via ftp. Is there any trouble currently with sftp?

Thanks,

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2019-07-22
Last reply:
2019-07-22
Lokesh Mandvekar (lsm5) said : #1

lsm5+bot's karma page does show some activity though: https://launchpad.net/~lsm5+bot/+karma

Manfred Hampl (m-hampl) said : #2

It seems that the packages have been successfully built, but the publication in the PPA is "pending"
https://launchpad.net/~projectatomic/+archive/ubuntu/ppa/+sourcepub/10357788/+listing-archive-extra

Apparently all builds from the past 4 hours haven't been published yet, but are in "pending" status.

Manfred Hampl (m-hampl) said : #3

It seems that the problems with pending packages have been solved and your package cri-o-1.13 (1.13.9-1~ubuntu18.04~ppa1) for bionic has been published two hours ago.

Can you help with this problem?

Provide an answer of your own, or ask Lokesh Mandvekar for more information if necessary.

To post a message you must log in.