Remove upload for non-existent PPA

Asked by Steve Butler on 2019-05-26

I uploaded gnucash_3.5-0_source.changes to gnc-released instead of gnc-released-ppa. Now I can't upload to the correct PPA and had to change the source code version. Is there any way to remove the bad upload?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2019-05-26
Last query:
2019-05-26
Last reply:
2019-05-26
Best Colin Watson (cjwatson) said : #1

Uploads to non-existent PPAs are simply rejected; they don't have any persistent effect on our end.

Perhaps you're just referring to the fact that by default dput won't repeat an upload if it appears to have already been uploaded? If so, then that's entirely a client-side thing - you can just use the -f option to dput to disable that check.

However, I see that you've already uploaded gnucash 1:3.5-1 to gnc-released-ppa. You can never reuse that version in that PPA, and by default Launchpad will prevent you from going back to an earlier version (though this can be overridden if necessary). Is it a problem to just leave 1:3.5-1 there?

Steve Butler (kg7je) said : #2

OK. Thank you. From the message I thought something on Launchpad was preventing the upload.

As for 1:3.5-1, not a problem (the build failed and I entered another question regarding that). So I presume I'll go through a number of attempts to get 3.5 built.

Thank you for the response and letting me know how to override that particular problem in the future.

--Steve

Steve Butler (kg7je) said : #3

Thanks Colin Watson, that solved my question.