Cannot import ed25519 OpenPGP key for PPA signing

Asked by dkg on 2019-05-01

for my dkg0 account, i'm trying to upload my current OpenPGP key, which is an ed25519 key:

pub ed25519 2019-01-19 [C] [expires: 2021-01-18]
      C4BC2DDB38CCE96485EBE9C2F20691179038E5C6
uid [ultimate] Daniel Kahn Gillmor <email address hidden>
uid [ultimate] Daniel Kahn Gillmor <email address hidden>
sub ed25519 2019-01-19 [S] [expires: 2020-01-19]
sub ed25519 2019-01-19 [A] [expires: 2020-01-19]
sub cv25519 2019-01-19 [E] [expires: 2020-01-19]

when i try to do that i get the following error:

------------
 Launchpad could not import your OpenPGP key

    Did you enter your complete fingerprint correctly? (Help with fingerprints)
    Is your key in the Ubuntu keyserver yet? You may have to wait between ten minutes (if you pushed directly to the Ubuntu key server) and one hour (if you pushed your key to another server). (Help with publishing keys)
------------

however, the key is in the ubuntu keyserver: https://keyserver.ubuntu.com/pks/lookup?search=0xC4BC2DDB38CCE96485EBE9C2F20691179038E5C6&op=vindex

I notice that messages from launchpad related to other RSA keys include an OpenPGP Comment field that indicates that it is using GnuPG v1, which doesn't support elliptic curve keys at all. So it's possible that this is the problem. Launchpad should be using a modern version of GnuPG, though.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2019-05-01
Last reply:
2019-05-02
Colin Watson (cjwatson) said : #1

I'm not sure there's a bug about this; I thought there was but I couldn't find one. Please do press "Create bug report" on this to turn it into a bug.

This is indeed because we're using GnuPG v1. I tried to upgrade to a modern version a while ago but I ran into a huge slew of test failures, mainly because of the same sorts of things that Ian Jackson has been complaining about for some time (e.g. https://bugs.debian.org/840669). I would like to have another go at some point, but it may take a while.

dkg (dkg0) said : #2

Done now, bug created and linked here. The buttons at the bottom of this box include "Problem solved" and "I still need an answer", neither of which are applicable here -- i have an answer, and my problem is not solved :P so i'm not sure how to dispose of this question. Feel free to close it with whatever mechanism you think is appropriate. I'll be following up on the associated bug report.

Can you help with this problem?

Provide an answer of your own, or ask dkg for more information if necessary.

To post a message you must log in.