Can't build packages, depending on debhelper 11 - error dh_builddeb: Sorry, but 10 is the highest compatibility level supported by this debhelper

Asked by Mantas Kriaučiūnas on 2019-04-03

Can't build packages, depending on debhelper 11 on Xenial PPA - error "dh_builddeb: Sorry, but 10 is the highest compatibility level supported by this debhelper" appears, see:
https://launchpadlibrarian.net/417495565/buildlog_ubuntu-xenial-amd64.btrfs-progs_4.16.1-2ubuntu1_BUILDING.txt.gz

dpkg-deb: building package 'libbtrfs0' in '../libbtrfs0_4.16.1-2ubuntu1_amd64.deb'.
dh_builddeb: Sorry, but 10 is the highest compatibility level supported by this debhelper.
END failed--call queue aborted.
debian/rules:18: recipe for target 'binary' failed

I have debhelper 11 package in my repository and this debhelper is installed during build from my PPA, see https://launchpadlibrarian.net/417495565/buildlog_ubuntu-xenial-amd64.btrfs-progs_4.16.1-2ubuntu1_BUILDING.txt.gz :
[..]
Get: http://ppa.launchpad.net/baltix-members/ppa/ubuntu xenial/main amd64 debhelper all 11.1.4ubuntu1ed10vi2~ubuntu16.04.3
[..]
Selecting previously unselected package debhelper.
Preparing to unpack .../debhelper_11.1.4ubuntu1ed10vi2~ubuntu16.04.3_all.deb ...
Unpacking debhelper (11.1.4ubuntu1ed10vi2~ubuntu16.04.3) ...

The same problem is also with other packages, depending on debhelper 11 , like smartmontools:
https://launchpadlibrarian.net/414113326/buildlog_ubuntu-xenial-i386.smartmontools_6.6-1_BUILDING.txt.gz

Should I try to upload other debhelper 11.x version in my PPA?

Question information

Language:
English Edit question
Status:
Expired
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2019-04-06
Last reply:
2019-04-22
Mantas Kriaučiūnas (mantas) said : #1

It seems problem was in older versions of other packages, related to debhelper 11 - issue was solved by I adding ppa:litenstein/debhelper11-3-2-xenial to build-depends of ppa:baltix-members/ppa
I've noticed, that ppa:litenstein/debhelper11-3-2-xenial contains rebuilded pkgbinarymangler 129ppa-xenial1 against debhelper 11.3.2 , I've copied pkgbinarymangler 129ppa-xenial1 to ppa:baltix-members/ppa and will test if it's enough to build correctly.

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Open' state without activity for the last 15 days.