Build stuck in "Pending publication"

Asked by testing gpdb on 2019-02-04

I have two distribution (Xenial & Bionic) builds performed with same source tarball. Both build completed with the Xenial published build completing fine. However, the Bionic build appears to be stuck after a successful build. Earlier, I disabled the Xenial build and the Bionic was able to publish successfully when run by itself. Can you please review why the Bionic (18.04) post build is stuck in a "Pending publication" state?

https://launchpad.net/~gpdb-test/+archive/ubuntu/gpdb/+packages

Thank you,
-=e

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2019-02-04
Last query:
2019-02-04
Last reply:
2019-02-04
Best Colin Watson (cjwatson) said : #1

This build is permanently unpublishable because the version of the .deb is exactly the same as another .deb that's already been built in the same archive. This in turn is happening because you're specifically overriding the version used for the binary in your override_dh_gencontrol rule, and the logic you're using there doesn't take account of the 16.04 vs. 18.04 differences in your source versions.

I recommend that you simply stop overriding dh_gencontrol to set the binary package version. Doing so is usually a mistake except in specialised circumstances that your package doesn't seem to come under, and the problem you've run into here demonstrates exactly why it's usually a bad idea.

testing gpdb (gpdb-test) said : #2

Thanks Colin Watson, that solved my question.