Please delete source package with invalid version

Asked by Ethereum Build Automation on 2019-01-22

I accidentally uploaded a source tarball of version 0.5.4 of the Solidity package to https://launchpad.net/~ethereum/+archive/ubuntu/ethereum-static/+packages - while we are just releasing version 0.5.3 (0.5.4 is still in development).
Could someone please delete the source package so that I can upload the proper version 0.5.3?
The current version 0.5.3-develop-... is also just a pre-release of the package.

Thanks a lot!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Ethereum Build Automation
Solved:
2019-01-22
Last query:
2019-01-22
Last reply:
2019-01-22

I accidentally uploaded a source tarball of version 0.5.4 of the Solidity package to https://launchpad.net/~ethereum/+archive/ubuntu/ethereum-static/+packages - while we are just releasing version 0.5.3 (0.5.4 is still in development).
Could someone please delete the source package so that I can upload the proper version 0.5.3?
The current version 0.5.3-develop-... is also just a pre-release of the package.

Thanks a lot!

Colin Watson (cjwatson) said : #2

You can delete it yourself on https://launchpad.net/~ethereum/+archive/ubuntu/ethereum-static/+delete-packages; once the deletion has been fully processed you'll be able to upload versions lower than it.

You won't ever be able to reuse that *particular* version, but since it includes things like a datestamp I don't imagine that will be too much of a problem.

For the future, I recommend using the "~" separator rather than "-" as the character immediately after the principal upstream version number, so that when you get to a final release you can drop the suffix (e.g. 1:0.5.4~develop-... sorts before 1:0.5.4-1, while 1:0.5.4-develop-... sorts after 1:0.5.4-1). You can't do this for 0.5.3 now, but you could do it for later versions.

Wonderful, thanks!