Release not found even though PPA is published in the series

Asked by aslam karachiwala on 2019-01-17

Re: https://launchpad.net/~jrheinlaender/+archive/ubuntu/ppa?field.series_filter=bionic

This PPA is published in the Bionic series which is what I'm running. However, apt-get reports the following error:
=====
Err:19 https://launchpad.net/~jrheinlaender/+archive/ubuntu/ppa bionic Release
404 Not Found [IP: 91.189.89.222 443]
...
E: The repository 'https://launchpad.net/~jrheinlaender/+archive/ubuntu/ppa bionic Release' does not have a Release file.
=====

The repo's maintainer, on the other hand, sees the following (see https://sourceforge.net/p/ooo-imath/bugs/28/):
=====
OK:6 http://ppa.launchpad.net/jrheinlaender/ppa/ubuntu bionic InRelease
=====

The line in my /etc/apt/sources.list is:
=====
deb https://launchpad.net/~jrheinlaender/+archive/ubuntu/ppa bionic main
=====

What's causing the "404 Not Found" for me?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2019-01-18
Last query:
2019-01-18
Last reply:
2019-01-18
Best Colin Watson (cjwatson) said : #1

Your sources.list line is wrong; that's the URL to the web UI, not the one usable by apt. It should be:

  deb http://ppa.launchpad.net/jrheinlaender/ppa/ubuntu bionic main

We normally recommend using the add-apt-repository tool instead of doing this manually, which also deals with importing the correct archive signing key. To do that, remove the line you (presumably) added manually and run:

  sudo add-apt-repository ppa:jrheinlaender/ubuntu/ppa

aslam karachiwala (akwala) said : #2

Thanks @cjwatson!

I used add-apt-repository but provided the wrong URL -- I wondered why the lines got written to /etc/apt/sources.list as opposed to a separate file in /etc/apt/sources.list.d/.

aslam karachiwala (akwala) said : #3

Thanks Colin Watson, that solved my question.