import from github fails

Asked by Cecilio Salmeron on 2018-07-23

I'm reopening this question https://answers.launchpad.net/launchpad/+question/306437

I have tried again today and the problem persists.

The log information is not meaningful to me so I do not know what to do to fix this. Please, help me!

Since I moved the repos to github in 2016 I'm being unable to prepare packages for Ubuntu. I would like to update packages for more recent Ubuntu versions but without your help this will not be possible.

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2018-07-23
Last query:
2018-07-23
Last reply:
2018-07-23
Colin Watson (cjwatson) said : #1

Do you actually need an import specifically to Bazaar? These days you can do an import to a Launchpad-hosted git repository and use source package recipes based on that, which is generally a much more robust operation as there are fewer things to go wrong.

Cecilio Salmeron (s-cecilio) said : #2

No, I wouldn't mind changing the type of repo. at Launchpad. Currently, the only service I need from Launchpad is the PPA and the ability to build packages for the different Ubuntu versions.

How should I do it?

Best Colin Watson (cjwatson) said : #3

Follow these documents:

  https://help.launchpad.net/Code/Git#Mirroring_repositories_from_other_sites
  https://help.launchpad.net/Packaging/SourceBuilds/Recipes

Just watch out for https://bugs.launchpad.net/launchpad/+bug/1623924; it's easy to work around but a bit confusing when you aren't expecting it.

Cecilio Salmeron (s-cecilio) said : #4

Thanks Colin Watson, that solved my question.

Cecilio Salmeron (s-cecilio) said : #5

Thank you very much indeed.