PPA key apparently lost in the void; keyserver.ubuntu.com can't find it.

Asked by Gregorio Litenstein on 2018-07-07

I created my first ppa yesterday, in a probably futile attempt to backport several packages to trusty; today, in trying to sort out dependencies and finding where exactly the builds are going wrong, I tried adding the ppa to a machine running trusty and I noticed the repository can't be added because it cannot find the key.

According to my PPA's page (https://launchpad.net/~litenstein/+archive/ubuntu/icu), the key should be https://keyserver.ubuntu.com/pks/lookup?fingerprint=on&op=index&search=0x1E0A4B32AA748B9D11C4528301A509285F2EA337

But that just says "No keys found."

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-07
Last reply:
3 hours ago

Just to test, I disabled the PPA and created a new one. I uploaded the one package that built succesfully; however, the new ppa has the exact same signing key, and it still isn't available on keyserver.ubuntu.com.

Simon Déziel (sdeziel) said : #2

I just ran into the same issue today.

Pavlushka (pavelsayekat) said : #3

I ran into the same problem for my PPA.

From what I was told in IRC, seems somebody needs to manually access the signing server that generates these keys and push them to the keyserver, but I have no idea when this will happen.

William Hughes (whlabratz) said : #5
LinTaro (lintaro) said : #6

I'm having the same problem with my PPA.

Jake Harr (jakar) said : #7

I'm also having this same problem.

Yesterday, I also had trouble adding my personal key to the keyserver (before creating the PPA), but with many repeated attempts (and trying other keyservers), that finally worked. Whatever that issue was, it could be related.

At least two others seem to have encountered the earlier keyserver problem: https://askubuntu.com/questions/1056567/sync-pgp-key-with-ubntu-keyserver

Simon Déziel (sdeziel) said : #9

I tested all PPA keys referenced in here and they are now available so marking as answered.

Can you help with this problem?

Provide an answer of your own, or ask Gregorio Litenstein for more information if necessary.

To post a message you must log in.