Fail to build package - says missing public key

Asked by Takkat on 2018-07-01

Today I uploaded an update of my python source package stream2ip (https://launchpad.net/stream2ip) to my ppa. As always I built and signed it on 16.04 with

   `sudo dpkg-buildpackage -S -sa -rfakeroot -kE8CC5F52'

I did not change anything with my pub key E8CC5F52 which is not expired and is listed on `gpg --list-keys'

Still, the build fails with

    Err:2 http://ppa.launchpad.net/takkat-nebuk/takkat/ubuntu bionic InRelease
    The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7991D1D1ABA5AAB4

Build log see: https://launchpadlibrarian.net/376692479/buildlog_ubuntu-bionic-amd64.stream2ip-gtk3_1.1.4-ppa0_BUILDING.txt.gz

I can't figure out what I had missed. Did anything important change since my last upload in 12/2017?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2018-07-01
Last query:
2018-07-01
Last reply:
2018-07-01
Best Colin Watson (cjwatson) said : #1

This is a temporary problem; the keyserver network has been having some difficulties recently and this occasionally causes builds to fail in this way. I've retried the builds that have been affected by this today, but you seem to have deleted this source package which means that I can't retry it. If it happens to you again then you can normally simply retry the build from Launchpad's web UI - no need to reupload, delete, or anything like that.

Takkat (takkat-nebuk) said : #2

Thanks Colin Watson, that solved my question.