Does this work in Debian?

Asked by OwN on 2018-05-22

Does this PPA work in Debian? I really need to get Apache 2.4.26+ installed on Debian 7, 8, and 9 as well.

Here's an error log when I try to use this PPA on debian:

http://forums.debian.net/viewtopic.php?f=10&t=137589

Edit, evidently asking a question doesn't link the question to the PPA's answers page, so the PPA is:

https://launchpad.net/~ondrej/+archive/ubuntu/apache2

Sorry, this launchpad question system isn't very straight forward as far as I can tell.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-05-24
Last query:
2018-05-24
Last reply:
2018-05-22
Best Manfred Hampl (m-hampl) said : #1

Try replacing the release indicator from "cosmic" to "bionic" in the sources.list file for the PPA

see https://wiki.ubuntu.com/Releases for the Ubuntu releases and release names.
Bionic is the current release, cosmic is the work-in-progress version to be published in October 2018.
Most PPAs do not yet provide software for that release.

OwN (own3mall) said : #2

Yep, this works on Debian 9:

sed -i "s/cosmic/xenial/g" "/etc/apt/sources.list.d/ondrej-ubuntu-apache2-cosmic.list"

Thanks for your help and for the information. The Debian community is rather toxic on the other hand:

http://forums.debian.net/viewtopic.php?f=10&t=137589

OwN (own3mall) said : #3

Thanks Manfred Hampl, that solved my question.