Please increase quota for ppa:deadsnakes/ppa

Asked by Felix Krull on 2018-05-06

Hi,
please increase the quota for https://launchpad.net/~deadsnakes/+archive/ubuntu/ppa. In addition to the usual growth over time, we're also thinking of supporting more architectures.
Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Felix Krull
Solved:
2018-05-07
Last query:
2018-05-07
Last reply:
2018-05-06
Colin Watson (cjwatson) said : #1

Are Python versions quite as old as 2.3 still needed? I'd have thought rather a lot of interesting modules didn't support that any more ...

Anyway, I've given it a quota bump.

Felix Krull (fkrull) said : #2

Thanks for the generous bump!

As for your question: the last time I tried to remove the really old ones, someone reported that they still use it for some hellishly outdated system or device that used Python 2.3. That was as recent as a few years ago. I don't think we can get any stats on how many people actually still use the old versions, either. It's mostly a case of "we have them, we might as well upload them", but I wouldn't rule out that someone uses the 2.x packages as a somewhat modern development environment for some equipment that shall never be upgraded.