firefox and xulrunner po translations

Asked by Reşat SABIQ on 2009-04-06

Do i understand correctly that the imports for these should be in xpi format, w/o having to transform the xpi into po format?

P.S. I'm basing this on https://answers.launchpad.net/rosetta/+question/40717
but i'm not quite sure i understood it right, and it's a bit old. Given that this appears to be the last week for jaunty, i'd appreciate any feedback on this.
P.P.S. If xpi has to be converted to po, then i'm wondering how the msgcontxt and line numbers are populated. I don't get those w/ translate-tools 1.1.1. I wonder if it would be done automatically by translate-tools 1.3, or would require manually populating them via a custom script.

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2009-04-14
Last reply:
2009-04-15
Henning Eggers (henninge) said : #1

Rosetta does support the XPI format natively so there is no needs to convert them to po format.

Cheers, Henning

Jeroen T. Vermeulen (jtv) said : #2

Indeed, imports for these projects should be in XPI, not in gettext format. If you have any questions about how the translations of these projects are set up, ask in the #ubuntu-mozillateam IRC channel.

Reşat SABIQ (tilde-birlik) said : #3

Guys, i think i walked right into the same pitfall as the guy question 40717. Could you please import the xpi as was done for that queston from here
https://addons.mozilla.org/en-US/firefox/addon/7420
or here
https://addons.mozilla.org/en-US/firefox/downloads/latest/7420

P.S. Since i tried po first, apparently it's stuck thinking that xpi imports are in po format for me too:
"We were unable to import the file because of errors in its format:

Line 1: Invalid content: u'PK\x03\x04'"

Reşat SABIQ (tilde-birlik) said : #4

Please import it for crh:
https://translations.launchpad.net/ubuntu/jaunty/+source/firefox-3.0/+pots/firefox/crh/+upload
https://translations.launchpad.net/ubuntu/jaunty/+source/xulrunner-1.9/+pots/xulrunner/crh/+upload

It now has the same note on upload page as the guy in 407717 was getting: This should be a .po file. If you don't upload for me, please at least clear that status bit so that it works when i try next time. I just tried 5 minutes ago, but it's gonna fail again.

Jeroen T. Vermeulen (jtv) said : #5

Reşat, do you have an XPI file to upload? That's how I fixed it last time.

Reşat SABIQ (tilde-birlik) said : #6

Hi Jeroen,

I was thinking it would be redundant for me to attach it, since it can be downloaded from here:
https://addons.mozilla.org/en-US/firefox/addon/7420
or here
https://addons.mozilla.org/en-US/firefox/downloads/latest/7420

The 1st link would require non-mozilla browser, but the 2nd one should also be usable w/ wget:
wget.exe --no-check-certificate https://addons.mozilla.org/en-US/firefox/downloads/latest/7420

Please let me know if i should attach it here.

P.S. The locale there is crh-UA, but i think that should be OK.

Thanks!

Reşat SABIQ (tilde-birlik) said : #7

I posted an update to the existing bug regarding this issue w/ a .xpi attachment, and also referenced the same link as above:
https://bugs.launchpad.net/rosetta/+bug/264101/comments/1

Please upload one of those 2 .xpi files.

P.S. Sorry if that wasn't the right place to upload .xpi to: since the link yesterday escaped attention, i wanted to make sure the .xpi location is obvious this time.

Thanks!

Jeroen T. Vermeulen (jtv) said : #8

I see you're a member of the translation team. I think you should see an upload option here, so you can fix it yourself: https://translations.launchpad.net/ubuntu/jaunty/+source/firefox-3.0/+pots/firefox

If you do upload there, make sure the file is called "crh.xpi"

Reşat SABIQ (tilde-birlik) said : #10

The .xpi import has indeed worked, but apparently it's not been released w/ 04/10 full export from launchpad. The following package is still not being built:
https://launchpad.net/ubuntu/+source/language-support-crh

I updated my other long-standing bug on language support for crh in this regard:
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/335307

If there are no doubts that .xpi import worked as expected, i'll close this question out in a while.

Thanks.

It should have been imported fine. For language support, I suggest you talk to Arne Goetje (https://launchpad.net/~arnegoetje).

Can you help with this problem?

Provide an answer of your own, or ask Reşat SABIQ for more information if necessary.

To post a message you must log in.