Build not finding dependencies within same ppa

Asked by Timescale on 2018-01-18

I have several packages that seem unable to find dependencies for some series (but not others) within the same PPA.

One example is:
https://launchpad.net/~timescale/+archive/ubuntu/timescaledb-exp/+build/14242960

Both the dependencies it says will not be installed are within my PPA, so I'm not sure where the problem is coming from. Any insights?

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-18
Last reply:
2018-01-18
Colin Watson (cjwatson) said : #1

It's not so much that it can't find the dependencies, but that they're uninstallable. (apt's error messages are a bit unhelpful, but that's what "is not going to be installed" means.)

I recommend setting up a chdist instance (from ubuntu-dev-tools), or, failing that, setting up an appropriate chroot with your PPA in /etc/apt/sources.list, and trying to install the package(s) in question in that environment; you can then drill down by adding more packages to the "apt-get install" line until you get a useful error message. Come back to us if you can't figure it out that way and we'll take a closer look.

Manfred Hampl (m-hampl) said : #2

Just a remark: Zesty is already EOL, see https://wiki.ubuntu.com/Releases

Timescale (timescale) said : #3

Thanks, I was able to figure it out.

I did post the wrong link, meant to link to artful instead of zesty. But speaking of being obsolete, is there anyway to keep packages updated for obsolete versions of Ubuntu? We do still see occasional users on Yakkety and probably Zesty.

Can you help with this problem?

Provide an answer of your own, or ask Timescale for more information if necessary.

To post a message you must log in.