Launchpad build recipe fails, but local sbuild works fine

Asked by Robert Tari on 2017-11-28

I am building from this branch:
http://bazaar.launchpad.net/~robert-tari/aacgain/trunk/files

with this recipe:
https://code.launchpad.net/~robert-tari/+recipe/aacgain-daily

into this repository:
https://launchpad.net/~robert-tari/+archive/ubuntu/main

Until recently aacgain had been building without problems, but now the recipe fails for every series and architecture. I have the very same source in sbuild setup locally, and I am able to build everything from Trusty to Bionic. Since I have no access to config.log, I cannot tell where Launchpad's configure process fails.

Thanks for any help in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
William Grant
Solved:
2017-11-28
Last query:
2017-11-28
Last reply:
2017-11-28
Best William Grant (wgrant) said : #1

Your build uses ccache, and ccache by default expects to be able to write to $HOME, which isn't possible in Launchpad builds. The problem is reproducible if you match your environment to the one listed in "User Environment" in the log. You should probably not try to use ccache in Launchpad, as each build runs in an ephemeral VM so no inter-build sharing is possible.

This behaviour changed in August, when launchpad-buildd switched to sbuild's more modern schroot mode rather than the sudo mode it used before. Launchpad now more closely matches the environment provided by the default sbuild configuration, so I'm surprised that your local sbuild setup didn't hit this problem long ago.

Robert Tari (robert-tari) said : #2

Locally, I have ccache installed manually (it's a setup reflex). I presumed it would be present in Launchpad's environments as well. I have removed it now and it builds.

There was another thing I had to alter that did not cause any trouble locally, though: Launchpad does not seem to like quilt in debian/rules in case of 3.0 (quilt) builds.

A big thank you for the help - I would never have solved this on my own.

Robert Tari (robert-tari) said : #3

Thanks William Grant, that solved my question.