Disable tests during build

Asked by Angel L. Mateo on 2017-11-10

Hello,

I'm trying to upload a package for a perl library (Net::RabbitMQ).
I have already compiled it in my system and the resulted library works without any problem, but I can't create the package in the launchpad.
The problem is that I have created the package with dh-make-perl and it runs tests during build. But these tests need a rabbitmq server running with a user to make the tests. So the build fails in your servers.
Is there any way I could upload the package configured in a way so tests are skipped during build?

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2017-11-10
Last reply:
2017-11-10
Angel L. Mateo (amateo) said : #1

Building locally there is the option to set DEB_BUILD_OPTIONS=nocheck to skip tests.
I'm asking for a similar way of doing this in launchpad build.

Colin Watson (cjwatson) said : #2

Since you're using the short debian/rules style with dh, you can add this to the end of that file (with make-style indentation using a tab rather than leading spaces):

# Disable tests, since they need a running RabbitMQ server.
override_dh_auto_test:

See the dh(1) manual page for more discussion of override rules.

Can you help with this problem?

Provide an answer of your own, or ask Angel L. Mateo for more information if necessary.

To post a message you must log in.