Cannot delete recipe

Asked by Jasem Mutlaq on 2017-11-09

I'm trying to delete the recipe here: https://code.launchpad.net/~mutlaqja/+recipe/libindi-daily-master

However, it always time out. I tried doing this repeatedly over the last 3 days with the same result!! Please delete.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Jasem Mutlaq
Solved:
2017-11-27
Last query:
2017-11-27
Last reply:
2017-11-09
Colin Watson (cjwatson) said : #1

Can you please give us the OOPS ID that should accompany the timeout?

Jasem Mutlaq (mutlaqja) said : #2

Sure

(Error ID: OOPS-034ae54ebdcf5dda0f2959fb33881a72)

Jasem Mutlaq (mutlaqja) said : #3

Any update on this? I just tried yet again and got this:

We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience.

Trying again in a couple of minutes might work.

(Error ID: OOPS-d38ce684a34a8534cffca6d6c3d7aa04)

Can you please delete this recipe??

Jasem Mutlaq (mutlaqja) said : #4

Still not update on this?

Jasem Mutlaq (mutlaqja) said : #5

I just tried again and was able to delete it. Thanks.

Colin Watson (cjwatson) said : #6

Mm, it's not exactly clear what might have been going wrong here since the statement that was taking nearly five seconds (UPDATE SourcePackageRecipeBuild SET recipe=NULL WHERE SourcePackageRecipeBuild.recipe = 18492) is on a table with an appropriate index; while it had to update a thousand or so rows, that shouldn't have been a big deal. When I try it on a non-production instance I see the first attempt taking about five seconds and the next taking under 100ms, so I think the table was probably just very cold and trying again did the trick. (I'm not sure why retrying didn't work before.)