oracle-java8-installer from ppa:webupd8team/java not working

Asked by Florin papa on 2017-10-18

I am having issues installing oracle-java8-installer from PPA webupd8team/java. It seems that Oracle moved some resources and that is why the package cannot be installed. I am using the latest Ubuntu 16.04 Docker image for this and I am accepting the license before running the command below. Does a bug need to be opened for this?

Please see the full output below:
root@test3-machine:/root# apt-get install oracle-java8-installer cassandra
Reading package lists...
Building dependency tree...
Reading state information...

[....] output omitted

Downloading Oracle Java 8...
--2017-10-17 22:42:47-- http://download.oracle.com/otn-pub/java/jdk/8u144-b01/090f390dda5b47b9b721c7dfaa008135/jdk-8u144-linux-x64.tar.gz
Resolving proxy-xxx
Connecting to proxy-xxx... connected.
Proxy request sent, awaiting response... 302 Moved Temporarily
Location: https://edelivery.oracle.com/otn-pub/java/jdk/8u144-b01/090f390dda5b47b9b721c7dfaa008135/jdk-8u144-linux-x64.tar.gz [following]
--2017-10-17 22:42:47-- https://edelivery.oracle.com/otn-pub/java/jdk/8u144-b01/090f390dda5b47b9b721c7dfaa008135/jdk-8u144-linux-x64.tar.gz
Connecting to proxy-xxx... connected.
Proxy request sent, awaiting response... 302 Moved Temporarily
Location: http://download.oracle.com/otn-pub/java/jdk/8u144-b01/090f390dda5b47b9b721c7dfaa008135/jdk-8u144-linux-x64.tar.gz?AuthParam=1508280560_0fde281eb156802d27b82b15daa05669 [following]
--2017-10-17 22:42:47-- http://download.oracle.com/otn-pub/java/jdk/8u144-b01/090f390dda5b47b9b721c7dfaa008135/jdk-8u144-linux-x64.tar.gz?AuthParam=1508280560_0fde281eb156802d27b82b15daa05669
Reusing existing connection to proxy-xxx
Proxy request sent, awaiting response... 404 Not Found
2017-10-17 22:42:48 ERROR 404: Not Found.

download failed
Oracle JDK 8 is NOT installed.
dpkg: error processing package oracle-java8-installer (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
oracle-java8-installer
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Florin papa
Solved:
2017-10-23
Last query:
2017-10-23
Last reply:
2017-10-18
Colin Watson (cjwatson) said : #1

We only provide the hosting; you'll need to take this up with the owner of the PPA in question (https://launchpad.net/~webupd8team).

windix (windix) said : #2

Hi Florin,

I got the same issue. The current work around based on webupd8 team's blog post: http://www.webupd8.org/2017/06/why-oracle-java-7-and-6-installers-no.html is to manually download jdk-8u144-linux-x64.tar.gz and put it under /var/cache/oracle-jdk8-installer/

Florin papa (fpapa) said : #3

I contacted the webupd8team admins about this and waiting for an answer. I know about the workaround, but I was relying on the old workflow for a Docker deployment.

I tried downloading Java8-u144 using wget, but since it is an older version, you cannot download it anymore without logging in to the Oracle Support website. That is probably why the webupd8team PPA is no longer working. I downloaded Java8-u151 as a workaround and that is probably what webupd8team should do as well.

I would really like the old workflow to function, as it is a much cleaner method.

Florin papa (fpapa) said : #4

The issue was solved, Java 8 was updated from u144 to u151 in the PPA.