SVN import of GRASS GIS stuck

Asked by Petr Viktorin on 2009-03-20

The import of is making no progress.
I'm afraid I can't be more helpful than that since I don't know what to look for in the logs.

Any idea what's wrong?

Question information

English Edit question
Launchpad itself Edit question
Steve McInerney Edit question
Solved by:
Michael Hudson-Doyle
Last query:
Last reply:
Anis CHEBBI (chebbi-anis) said : #1

try this link

since LP GRASS GIS svn is an import from that link

Christian Reis (kiko) said : #2

I'm pretty sure in all the failures I've seen the connection to the SVN server is timing out as we attempt to import it.

Petr Viktorin (encukou) said : #3

Anis, thank you, but I already have a workaround. I'd just be nice to have a proper imported branch in LP.

Christian, thank you as well. I've read about hackers tending to take questions literally; LP code import being closed-source threw me off a bit. I'll try to post more direct questions :)

Is this going to be fixed? If so, about how long should I expect it to take? How can I help? Should I file a bug for this? Should I try to interpret the tracebacks in the logs?

If we can get hold of a local copy of the svn repo, we can update the import from that...

Steve McInerney (spm) said : #5

FYI we now have a local import copy that should import successfully. Hopefully.

Petr Viktorin (encukou) said : #6

It still doesn't work. Probably just a typo in the path now.

Curtis Hovey (sinzui) said : #7

spm: The log says not found. Do you need to change the permission on that directory

Steve McInerney (spm) said : #8

Petr, yeah: correct path fail. fixed, but still died on the import.
Have pinged mwh, he's chasing.

It seems that the initial revision adds 18000 files and this is more than cscvs can cope with...

Markus Neteler (neteler) said : #10

Can we from the GRASS project help?

No, but there was something I could do. It fought a bit, but I managed to get the import to succeed at last:

Markus Neteler (neteler) said : #12

Glad to see the success. Note that we changed the SVN installation at OSGeo to be more performant. Apparently it contributed - hope that further updates aren't causing any new problems.

Petr Viktorin (encukou) said : #13

Thanks Michael Hudson, that solved my question.