Problem with emacs git import

Asked by Robert Bruce Park on 2017-05-15

Hi all,

I'm having trouble with a git import. See here:

https://code.launchpad.net/~ubuntu-elisp/emacs/+git/master

Digging into the logs, it appears that the upstream has done a major branch reorg (many deleted branches), and this is somehow causing problem.

My first thought was "No worries, I'll just delete the repo and create a new one"

Well, turns out lp won't let me delete it because somebody made a source package recipe that's using it and I don't have permission to delete that. Also I can't make a new one while the broken one still exists.

Would be real nice if:

1. Random people weren't able to hold my repos hostage

2. Somebody with magic powers could just blow the repo away and start fresh

3. git imports weren't so flaky. I don't care if upstream changed history or whatever happened here, all I want is a perfect mirror of what upstream has. 'git fetch --force' all the way

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2017-05-16
Last query:
2017-05-16
Last reply:
2017-05-16
Robert Bruce Park (robru) said : #1

I also tried deleting the problematic branches within the repo with no luck:

$ git push origin --delete source/feature/gnus-select
fatal: remote error: Permission denied.

$ git push origin --delete feature/gnus-select
fatal: remote error: Permission denied.

Colin Watson (cjwatson) said : #2

A number of git imports broke after the code import systems were upgraded to xenial, due to some subtle behaviour changes in git. I'm working on a fix now.

Best Colin Watson (cjwatson) said : #3

I've fixed this (https://code.launchpad.net/~cjwatson/launchpad/codeimport-git-xenial/+merge/324104) and the import is working again now. I'll sort out the other failed git imports when I get a few minutes. This was out-of-the-ordinary breakage due to a major upgrade, so I would expect the import to be generally robust from now on.

Robert Bruce Park (robru) said : #4

Thanks Colin Watson, that solved my question.