Import from Github is not working

Asked by Jasem Mutlaq on 2017-05-10

I started GIT import here but it's not importing anything in a couple of hours

https://code.launchpad.net/~mutlaqja/chartdownloader/master

Is there something wrong with my import address?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2017-05-10
Last query:
2017-05-10
Last reply:
2017-05-10
Best Colin Watson (cjwatson) said : #1

The import queue is substantially backlogged at the moment, because we recently upgraded the code import machines from precise to xenial, and this seems to have caused a database format change somewhere that requires all the bzr-svn-based imports to rebuild their revision caches from scratch. It isn't a problem with your import, and it should clear eventually once the system has rebuilt all its caches.

Do consider only creating a git-to-git import, though, rather than both a git-to-bzr import and a git-to-git import of the same repository. You should really only need one of them, and the git-to-git import is likely to be more robust.

Jasem Mutlaq (mutlaqja) said : #2

Ok thanks for the update, I'll do a git-to-git only import. Hopefully it will go through at some point!

Jasem Mutlaq (mutlaqja) said : #3

Thanks Colin Watson, that solved my question.

Colin Watson (cjwatson) said : #4

The queue has cleared now, so this should be behaving itself again.

How long on average would a new code configuration take to finish import from a git repository?