mirror branch lp:~dvc-dev/dvc/main refusing to update

Asked by Samuel Bronson on 2009-03-05

The mirror branch lp:~dvc-dev/dvc/main is refusing to update -- says something about a 403 but doesn't say for what URL.

Could it be related to the format having changed? Launchpad says:

Branch format: Branch format 5
Repository format: Knit repository format 1

But curl says:

% curl http://bzr.xsteve.at/dvc/.bzr/branch/format
Bazaar Branch Format 6 (bzr 0.15)
% curl http://bzr.xsteve.at/dvc/.bzr/repository/format
Bazaar pack repository format 1 (needs bzr 0.92)

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2009-03-09
Last reply:
2009-03-19
Samuel Bronson (naesten) said : #1

Oh, apparently "lp:" urls aren't autolinked here, so I'll spell it out: https://code.launchpad.net/~dvc-dev/dvc/main

Barry Warsaw (barry) said : #2

It looks like there could be a permission problem on the remote branch that's breaking the mirror. For example, locally I run the following commands:

% bzr branch http://bzr.xsteve.at/dvc
Branched 531 revision(s).
% bzr info http://bzr.xsteve.at/dvc
bzr: ERROR: Transport error: Server refuses to fulfill the request (403 Forbidden) for http://bzr.xsteve.at/dvc/.bzr/repository/shared-storage

So the initial branch works, but info on the remote branch doesn't, and I'm guessing the mirroring process needs 'bzr info' to work. If you have access to the remote branch, can you please check the permissions. If you don't have access, can you ask the person who does to check those permissions?

I don't have a shared-storage file/directory in this directory. What do
I have to do to get one?

Here is the content:

bzr.xsteve.at:/dvc/.bzr/repository:
  49 Dec 13 21:55 format
4096 Mar 2 21:44 indices
   6 Mar 2 21:44 lock
   6 Dec 13 21:55 obsolete_packs
 520 Mar 2 21:44 pack-names
4096 Mar 2 21:44 packs
   6 Mar 2 21:44 upload

William Grant (wgrant) said : #4

I don't think you need one. But if you don't have one, why is it 403ing rather than 404ing?

I have no influence wich error code my webprovider sends for a missing document.

My question is, how do I create a valid shared-storage file?
I don't know the bzr internals to setup such a mirror...

Samuel Bronson (naesten) said : #6

On Mon, Mar 9, 2009 at 6:45 AM, Stefan Reichör
<email address hidden> wrote:

> I have no influence wich error code my webprovider sends for a missing
> document.

You expect us to believe that when the domain name is bzr.xsteve.at
and you call yourself XSteve on some of your pages? Surely you have
*some* control over it!

Of course I have some control.
It is a hoster and I can upload files via ftp. A webserver serves the pages via http.
But I have no control over the webserver.

bzr is one of the systems that can be used on such a dumb host (I used tla before).
git, hg did not work with such a host in the past (I don't know if they can be used now).

My question still remains:
How can I setup a bzr repository that contains the needed shared-repository file.

Is it possible that the problem is, that I started this branch a long time ago.
bzr info -v gives the following:

stefan@pyramide:work/myprg/dvc% bzr info -v
Standalone tree (format: pack-0.92)
Location:
  branch root: .

<snip>

Format:
       control: Meta directory format 1
  working tree: Working tree format 4
        branch: Branch format 6
    repository: Packs containing knits without subtree support

In the working tree:
       133 unchanged
         0 modified
         0 added
         0 removed
         0 renamed
        41 unknown
        95 ignored
        10 versioned subdirectories

Branch history:
       532 revisions
        21 committers
      1006 days old
   first revision: Wed 2006-06-07 22:27:26 +0200
  latest revision: Fri 2009-03-06 21:52:16 +0100

Repository:
      1296 revisions

Vincent Ladeuil (vila) said : #8

bzr only checks for the existence of the file here, if the file exists, the repository is shared if it doesn't the repository is local to the branch.

In your specific case, I think you just don't care since you publish only one branch, so creating the file (empty) will resolve the issue.

I've filed https://bugs.launchpad.net/bzr/+bug/342119 to provide a more correct fix in the long term.

Thanks Vincent!

Adding an empty shared-storage file solves the problem.
At least bzr info is working now.

Mirroring of https://code.launchpad.net/~dvc-dev/dvc/main still does not work :-(

I hit the Try again button some times but I always get this message:

Launchpad no longer mirrors this branch, because 12 attempts failed. (Transport error: Server refuses to fulfill the request (403 Forbidden) for ...) If you have fixed the problem, please ask Launchpad to try again.

The message does not show which file causes the problem.
bzr info works now:

% bzr info http://bzr.xsteve.at/dvc
Repository branch (format: pack-0.92)
Location:
  shared repository: http://bzr.xsteve.at/dvc/
  repository branch: http://bzr.xsteve.at/dvc/

Related branches:
  parent branch: /home/stefan/dvc-mq.bundle

Can you help with this problem?

Provide an answer of your own, or ask Samuel Bronson for more information if necessary.

To post a message you must log in.