Wiki account not syncying with open_id credentials, after entering username and old password

Asked by Chris Crisafulli on 2009-02-03

Hey there!

I have an issue when I try to Login to this link: https://wiki.ubuntu.com/, it takes me to a launchpad login service page that shows all of my open id credentials. When I click on Sign-in, it prompts for a login using my user name itnet7 and asks me to enter my password. I try and enter my password and it rejects it. I have tried changing my password, but it doesn't seem as though it is syncing on the back end. I am currently using edge, but I am pretty sure it happened prior to that. Also close to six months ago I did a merge on the two launch pad accounts I had, everything seemed to go well except my join date reflected the more recent account, I am not sure if itnet7 in the https://wiki.ubuntu.com/ was working prior to the account merge and if my original older account being disabled would lead to this, but included this info just in case . For now I have been just entering 'itnetseven' but would like to be able to use my normal itnet7 account. I can login in directly with this link: https://help.ubuntu.com/community/ using my open-id, and never get prompted for the second ID.

Thanks for your time,

Chris Crisafulli
https://wiki.ubuntu.com/itnet7

Please let me know of any other info that you may needl

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
[LEGACY] Canonical WebOps Edit question
Solved by:
Andrew Glen-Young
Solved:
2009-03-16
Last query:
2009-03-16
Last reply:
2009-03-16
Whiteboard:
barry 20090206 assigned to losas flacoste 20090223 sent email losas to check that the OpenID identifiers are in sync
Brad Crittenden (bac) said : #1

Chris,

I think your browser has a cookie identifying you with your old LP id. Try clearing your cookies for ubuntu.com, closing your browser, and then revisiting wiki.ubuntu.com. I just did that in Firefox and verified that I had to enter my credentials anew.

There may be a chance that the wiki is holding onto your old LP id and it may need to be cleared. Try the cookie suggestion first and report back here if you need additional help.

Thanks,
Brad

Chris Crisafulli (itnet7) said : #2

Brad,

Thanks for your help, unfortunately it still doesn't work. I have tried it on multiple machines and had tried to clear the cache in the past (Forgot to mention that). I tried it again just now and it still doesn't work for me :-(. I do have to login a second time to Launchpad since I am using edge, do you think there may be any connection to the double LP authentication and this issue?

Here is some of the typical behaviour I have experienced:

1. Clear the Private data checking the cookies.
2. Login to https://launchpad.net/+login using my chris_cATlinuxsoulsDOTcom address.
3. I am taken to https://launchpad.net/ and my name appears in the upper right hand corner.
4. Click on my name in the upper right corner, and it goes to my overview page: https://edge.launchpad.net/~itnet7 and simultaneously makes my name disappears in the upper right hand corner and says: Log in/Register once again.
5. click on Log in/Register and it prompts me for my credentials, which I use the same ones, and then I'm in fully in to Launchpad.

At any time during either login I get the same results when trying to log in to the wiki.ubuntu.com.

When I try to login to the wiki.ubuntu.com I do the same as above. When I get prompted to use my password for itnet7, no matter what password I try to use it fails. So I choose to click Log in/Register link in the upper right hand corner of the page asking me for the password for itnet7. It shows me my openID credentials, listing itnet7 which is the account I am trying to authenticate with.

Here is the OpenID stuff that comes up:

Sign in as Chris Crisafulli?

These details will be sent to Ubuntu Wiki:

    * Chris Crisafulli
    * itnet7
    * <email address hidden>
    * America/New_York

By clicking Sign in, I just continue to get asked for my password for itnet7. Seems kind of strange since itnet7 is clearly listed there.

Hope this helps. I can send some screen shots if there is any clarification needed. I read in some similar issues as this that there is the possibility of a zombie account being in the wiki.ubuntu.com. is there a chance the current account for itnet7 can be renamed so I can re-register it? Also is there a chance that the account itself has been permanently disabled on accident?

Thanks for your time,

Chris

Brad Crittenden (bac) said : #3

Chris,

The IS guys have made some changes on the wiki.ubuntu.com side. Please try again.

Chris Crisafulli (itnet7) said : #4

Brad,

I have tried it again and unfortunately it still continues to prompt me for the password. Thanks so much for continuing to work on this, I would let this go, but I would like to be able to edit my loco team wiki seamlessly.

Thanks for your time.

Chris

Barry Warsaw (barry) said : #5

Chris, I just tried to verify this with my own account and had no trouble getting into wiki.ubuntu.com (even though the latter was very slow). So I don't think this is indicative of some openid session problems we've been having lately. That jives with the fact that clearing your cookies doesn't help.

I don't think the edge/non-edge double login is coming into play here.

I'm assigning this issue to the Launchpad admins because you maybe right that it's a problem with your account merge.

Chris Crisafulli (itnet7) said : #6

Please keep me updated... It would be great to be able to use my own account again to edit on the loco wiki :-)

Francis J. Lacoste (flacoste) said : #7

I suspect that what is happening is that the OpenID identifier linked to your Wiki account is the identifier of your old account. Since Launchpad is returning the new one, the wiki might reject it and ask you to log it again.

I'm chasing this hypothesis right now...

Chris Crisafulli (itnet7) said : #8

I noticed I had an unmerged account from January of this year somehow. So I merged the accounts in launchpad. Although this may not be entirely relevant I thought I should mention it.

Chris,

I have updated your Moin user profile. Please try again and login with your Lauchpad id 'itnet7' and let me know the results.

AFAIK this is a bug in the Moin OpenID module and we are currently working on a fix (#342431).

Chris Crisafulli (itnet7) said : #11

Andrew,

Thanks so much, it is now working perfectly.

Chris Crisafulli

Claudio (der-claudio) said : #12

Hi!

I wanted to contribute to the wiki for the first time today. And I've got exactly the same problem.

> Sign in as Claudio Harringer?
>
> These details will be sent to Ubuntu Wiki:
>
> * Claudio Harringer
> * der-claudio
> * <email address hidden>
> * Europe/Vienna

Then comes the password prompt at the wiki site which won't let me in. ("Wrong password...")

The first time I tried I also got a error message. Probably the debug info there helps you. I've replace my password in that html file to XXX-password-hidden-XXX. See there:

http://nopaste.de/p/a2QWZt0pnb