First push from Bazaar does not work

Asked by Ralf Hersel on 2009-01-14

Hello
I'm using Bazaar 1.11rc1 on WinXP. My first attempt to push into Launchpad does not work. Here is what happens:

bzr launchpad-login ralf.hersel
bzr push lp:~ralf.hersel/hivegame/initial
bzr: ERROR: Unable to connect to SSH host bazaar.launchpad.net; (10061, 'Connection refused')

Yes, I have a bazaar snapshot of my code.
Yes, I have a ssh-rsa public key in Launchpad.

But I don't know how to use my private ssh key when pushing to Launchpad.

How can I connect and push to Launchpad?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Ralf Hersel
Solved:
2009-01-22
Last query:
2009-01-22
Last reply:
2009-01-22
Ralf Hersel (ralf.hersel) said : #1

I also tried this comand:

bzr push bzr+ssh://<email address hidden>/~ralf.hersel/hivegame/firstshot --use-existing-dir

It returns with the same error message.

Ralf Hersel (ralf.hersel) said : #2

Ok, I forgot to run Pageant and add the private key. That's done now but 'bzr push...' still does not connect to Launchpad.

Ralf, can you push from bzr to other servers using bzr+ssh ?

Ralf Hersel (ralf.hersel) said : #4

Hi Tom, I tried it with another server but I'm not shure what the result means:

I:\My Documents\My Private\Python\Hive>bzr push bzr+ssh://core@10.33.2.59
Connected (version 2.0, client OpenSSH_4.7p1)
Adding ssh-rsa host key for 10.33.2.59: AC71124AABDA3A4D54D951EF29BF7CEF
Authentication (publickey) failed.
SSH core@10.33.2.59 password:
Authentication (password) successful!
Secsh channel 1 opened.
bzr: ERROR: Connection closed: please check connectivity and permissions (and try -Dhpss if further diagnosis is require
d)

Christian Reis (kiko) said : #5

Does that last command fail over multiple attempts or just the first one?

Ralf Hersel (ralf.hersel) said : #6

Problem solved.
From my Linux PC utilizing Olive it works fine.