Proposing branches for merge via email is oopsing

Asked by Elliot Murphy on 2009-01-13

Hi! I tried proposing a branch for merge using bzr send --no-bundle, and I got an error email back. It told me to file this question, and reference OOPS-1109CEMAIL10 in the description.

I'm doing this with private branches, dunno if that might have something to do with it. I have things configured as described here: https://dev.launchpad.net/Code/BzrSend.

Also, I did gpg sign my email.

Can you help me get this working?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Aaron Bentley Edit question
Solved by:
Aaron Bentley
Solved:
2009-01-19
Last query:
2009-01-19
Last reply:
2009-01-19
Whiteboard:
Aaron - can you take a look at this please?
Elliot Murphy (statik) said : #1

Well I got bored with waiting for a response (we're all so busy!), so I looked up the OOPS myself. What can I say, I think this is an incredibly cool feature and I want to use it right now.

Here is the traceback:

Traceback (most recent call last):
  Module canonical.launchpad.mail.incoming, line 292, in handleMail
    handled = handler.process(mail, email_addr, file_alias)
  Module canonical.launchpad.mail.codehandler, line 225, in process
    self.processMergeProposal(mail)
  Module canonical.launchpad.mail.codehandler, line 360, in processMergeProposal
    source, target = self._acquireBranchesForProposal(md, submitter)
  Module canonical.launchpad.mail.codehandler, line 323, in _acquireBranchesForProposal
    raise NonLaunchpadTarget()
NonLaunchpadTarget

I've got some weird stuff configured in my locations.conf for the strange PQM setup that we have, I'll be working with the LOSAs to change our PQM config so that we can fix the branch locations and not confuse launchpad.

However, this should not be an OOPs, the error email I get back from launchpad should say that the merge proposal could not be accepted because the target branch was not a launchpad branch. I'll be able to get things working now, I think this question should be converted into a low-priority bug to fix the error message that is emailed back from launchpad.

Another minor detail, the 'Submit Request Failure' email from launchpad comes from <email address hidden>, even though I sent the merge request to <email address hidden>

Aaron Bentley (abentley) said : #2

What is shown as the target branch in the merge directive?

Elliot Murphy (statik) said : #3

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This is the target_branch in the merge directive:

# target_branch: bzr+ssh://bazaar.ubunet/~ubunet-pqm-team/ubunet/trunk

We've got this configured this way as a hack for PQM, I think we need to
fix it on our side - I don't expect launchpad to be able to identify
this. But I think getting the not a launchpad branch error message back
would have enabled me to realize what was happening and fix it without
bugging anyone on the launchpad team.
- --
Elliot Murphy | https://launchpad.net/~statik/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkl0kLMACgkQGi43imCMARLlFACgiG+wrDFDEoGSXpvoD2mm4tL8
FaMAoJAsBWtt17oxN7MJ7ECh+uoyhuIq
=F5fe
-----END PGP SIGNATURE-----

Best Aaron Bentley (abentley) said : #4

You can also just set bzr+ssh://bazaar.ubunet/~ubunet-pqm-team/ubunet/trunk up as a mirrored branch or a remote branch.

Elliot Murphy (statik) said : #5

Thanks for looking at this, and for the suggestions!