hangs when doing a push

Asked by Ramon Diaz-Uriarte on 2009-01-12

bzr hangs forever when I try to do

bzr push -v sftp://<email address hidden>/~rdiaz02/pomelo2/main

Note that I can create new repositories with that very same command (e.g.,

bzr push -v sftp://<email address hidden>/~rdiaz02/pomelo2/main01

)

but then, I cannot commit to them.

This is a _very large_ repository (> 650 MB).

Note that other projects (much smaller, though) are updated just fine from the same machine.

Thanks,

Ramon

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Aaron Bentley Edit question
Solved by:
Paul Hummer
Solved:
2009-01-12
Last query:
2009-01-12
Last reply:
2009-01-12
Whiteboard:
Assigned to abently 2009-01-12 henninge
Best Paul Hummer (rockstar) said : #1

There are a couple of issues here. First, it's best to use bzr+ssh instead of sftp. That'll fix the push problem, because your branch called 'main' is using Branch Format 6, so you'll get the benefits of stacking that way. You're currently not using the benefits of the smart server. This will make the pushes after the first much faster.

The other issue is that you're uploading 650 Mb of data, which is going to take an awful long time. There is a bazaar bug for giving you more feedback on the progress bar, letting you know where it is in the process.

Ramon Diaz-Uriarte (rdiaz02) said : #2

Thanks! It works great with bzr+ssh. (And, yes, the initial push of the 650 MB is slow; what was not working, though, were the additional pushes; but now they do).

Ramon Diaz-Uriarte (rdiaz02) said : #3

Thanks Paul Hummer, that solved my question.