bzr+http mirrored branch fails with bzr error

Asked by Mark Lee

My mirrored branch <> is a bzr+http branch, with the bzr server running bzr 1.9 (the branch format is pack-0.92, working tree-less branch in a repository).

The following error is on my branch page:

"Launchpad no longer mirrors this branch, because 6 attempts failed. (AttributeError: 'KnitPackRepository' object has no attribute '_real_repository')"

When users have encountered this error when trying to fetch the primary branch, upgrading to at least 1.9 resolves the problem. Do I have to wait for Launchpad to upgrade for it to resume mirroring?

Question information

Revision history for this message
Matt Nordhoff (mnordhoff) said :

Launchpad upgraded from 1.7.1rc1 to 1.10 a few weeks ago. If you want it
to try mirroring again, there should be a retry button on the branch page.

Revision history for this message
Mark Lee (malept) said :

Strange, I just retried and the same error occurs. The same error went away for a user after upgrading to 1.10 in this bug:

Revision history for this message
Best Andrew Bennetts (spiv) said :

It appears that the branch is accessible via bzr+http, but the branch's repository isn't (it is only accessible via HTTP).

I think there are two bugs here:

 1) The server is misconfigured. If a branch's repository isn't accessible via the same protocol/connection as the branch itself, then that branch is unusable.
 2) The client doesn't report the problem gracefully or clearly.

You should be able to workaround the misconfiguration by using "nosmart+http://..."

Revision history for this message
Mark Lee (malept) said :

Thanks Andrew Bennetts, that solved my question.