vcs-imports : monodevelop is hung

Asked by Michael B. Trausch on 2008-10-06

I am not sure if the import repository needs to be dropped and re-added, or if something else needs to be done manually to rectify the situation, but the "monodevelop" repository needs to be brought up to date; it was last done near the end of last year.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Michael Hudson-Doyle Edit question
Solved by:
Michael Hudson-Doyle
Solved:
2008-10-13
Last query:
2008-10-13
Last reply:
2008-10-13
Michael B. Trausch (mtrausch) said : #1

I ran a 'bzr branch' of the upstream MonoDevelop SVN repository last night, and it ran without error. Have done a couple of 'bzr pull' operations since then, as well, and am finding that it is working. So, it looks like if there is no easy way to force the repository to reflect the current SVN repository, that it should be removed and restarted—at least, a fresh checkout and subsequent pulls are working for me, using bzr 1.6.1 on Intrepid with Intrepid's bzr-svn.

Edwin Grubbs (edwin-grubbs) said : #2

This question has been assigned to someone who can troubleshoot the issue.

I have to admit that I'm not sure what is going on here. The import tool -- which is cscvs, by the way, not bzr-svn -- seems to have been confused by the trunk branch being replaced by another branch in the svn repository -- but I'm sure that this usually doesn't cause problems so I'm a bit confused.

One option would be to try a new import from scratch, but this would produce an entirely separate branch that, as far as Bazaar knew, had no common ancestry with the current one. Would that be acceptable?

I'll dig a bit more and get back to you.

Michael B. Trausch (mtrausch) said : #4

I can't speak for anyone else, but yes, it'd be acceptable as far as I am concerned if it restores the ability to branch it with bzr and get a current tree. Currently, I am still using the upstream SVN repository. I haven't modified it yet, since I am just looking at the code to get an idea of the way it is structured in whatnot, though I have modifications in mind in the future. :-)

In any case, thanks for digging into it. I am eager to be able to branch from here soon.

OK, I've shuffled things around a bit and registered a new import and subscribed you to the branch. It has the same url as the old one (https://code.edge.launchpad.net/~vcs-imports/monodevelop/trunk) and the old one has been renamed (https://code.edge.launchpad.net/~vcs-imports/monodevelop/trunk-old).

Let's see what happens.

On looking, I think the problem stems from there being a revision – r90711 – where there is nothing at /trunk/monodevelop (it's added back in the next revision). Perhaps I can get cscvs to skip over this revision somehow... but let's see if the new import works first.

The new import succeeded: https://code.edge.launchpad.net/~vcs-imports/monodevelop/trunk

Chalk another one up to code import mysteries.

Michael B. Trausch (mtrausch) said : #7

Thanks Michael Hudson, that solved my question.