how to install the TracLaunchpad plugin with trac-0.11.1

Asked by Zooko Wilcox-O'Hearn on 2008-10-01

Folks: I just tried to follow these steps to install the trac-launchpad integration plugin https://help.launchpad.net/Bugs/TracPlugin

I maintain this trac instance:

http://allmydata.org/trac/tahoe

Which is running trac-0.11.1, and has the following 4 items listed on the plugins page:

Trac 0.11.1
NavAdd 0.1
TracAccountManager 0.2.1dev-r3857
TracDarcs 0.6-24

My first question is: why does the instruction page, in the "Activating the plugin" section, have the comment "# for 0.10"? Does this mean that all of part of that section is unnecessary for my Trac v0.11.1 installation?

My next question is, given that I went ahead and followed these instructions, why does the TracLaunchpad plugin not appear in the list of plugins at http://allmydata.org/trac/tahoe/admin/general/plugin ?

Finally, when per the instructions I run this commandm it fails:

$ trac-admin . permission add launchpad XML_RPC
Command failed: XML_RPC is not a valid action.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
Graham Binns Edit question
Last query:
2008-10-08
Last reply:
2008-10-13
Graham Binns (gmb) said : #1

To be able to use the Launchpad plugin you need to have installed the TracXMLRPC plugin first (http://trac-hacks.org/wiki/XmlRpcPlugin). It's in the list of prerequisites for the plugin but it's pretty unclear that it needs to be installed first; I've updated the page. Not having the XML-RPC plugin installed is the reason for the 'permission add' command failing.

The '# for 0.10' comment is an error; leave that config section in and it won't do any harm in your 0.11 installation.

Let me know if you have any more problems.

Graham Binns (gmb) said : #2

Also, I suspect the XML-RPC plugin not being installed is the reason for the Launchpad plugin not showing up in the list of plugins. Let me know if it doesn't show up once you've installed the XML-RPC plugin.

Zooko Wilcox-O'Hearn (zooko) said : #3

Thank you very much. After installing XmlRpcPlugin, everything else in the instructions worked. Then I went and added a comment to an issue that is linked between launchpad and the Tahoe trac (as well as several other bug trackers):

https://bugs.launchpad.net/allmydata.org/+bug/254035

However, I guess you haven't enabled launchpad on your end to push comments into my trac, because nothing happened over there. :-)

Graham Binns (gmb) said : #4

> However, I guess you haven't enabled launchpad on your end to push comments into my trac, because nothing happened over there. :-)

Right :). We need to tell Launchpad's bug watch checker to re-check the watches from the Tahoe Trac. I'll do that shortly and we should hopefully see a correct update within the next 24 hours.

Graham Binns (gmb) said : #5

We've come across an issue whilst trying to sync with the Tahoe Trac. I'm working on debugging this and will get back to you shortly.

Graham Binns (gmb) said : #6

Having debugged this, I discovered a bug with the default configuration for the Trac plugin which was preventing Launchpad from being able to authenticate with the Tahoe Trac: Bug 277289.

To resolve this, you can download and install the latest version of the plugin, 0.1.2-1, which is available here: https://edge.launchpad.net/trac-launchpad/trunk/0.1.2/.

Alternatively, you can add the following lines to your Trac instance's trac.ini to work around the problem:

[launchpad]
auth_server = https://launchpad.net/token/%s/+bugtracker-handshake

Zooko Wilcox-O'Hearn (zooko) said : #7

Okay, I just installed the latest version from that URL, which produced a bdist_egg named "TracLaunchpad-0.1.2-py2.5.egg" by the way. Now what?

Graham Binns (gmb) said : #8

Now, we'll try synching again. I'll let you know how it goes.

Zooko Wilcox-O'Hearn (zooko) said : #9

Should I try upgrading to a newer version of the TracLaunchpad plugin now?

Graham Binns (gmb) said : #10

The fix for the bug that was preventing syncing will be rolled out this week. We'll re-try syncing once it's rolled out.

Can you help with this problem?

Provide an answer of your own, or ask Zooko Wilcox-O'Hearn for more information if necessary.

To post a message you must log in.