copy-package fails with a different source with the same version is published in the destination archive

Asked by Ryan Harper on 2017-02-16

I'm attempting to copy package systemd from xenial-proposed into my ppa:raharper/snapbuilds.

I get the error:

Launchpad encountered an error during the following operation: copying package systemd. systemd 229-4ubuntu17 in xenial (a different source with the same version is published in the destination archive)

I did have a package named that in my ppa, but I've since deleted it via the Delete Package page on my PPA. That was 24+ hours ago. Browsing the ppa archive, there is only a directory named 'systemd' left , but nothing in the Release or actual debs.

http://ppa.launchpad.net/raharper/snapbuilds/ubuntu/pool/main/s/

What else can I delete to allow the copy-package to proceed?

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-16
Last reply:
2017-02-16
William Grant (wgrant) said : #1

It's not possible to upload a different package with the same version as another that has ever existed in a PPA. You'll need to change the version of the package if you want to copy it into that PPA.

Can you help with this problem?

Provide an answer of your own, or ask Ryan Harper for more information if necessary.

To post a message you must log in.