Problems in upload .po file

Asked by Paco Molinero on 2008-08-10

I have been try a couple of times to upload a .po file but every time I have been received:

On 2008-07-21 10:55+0000 (19 days 23 hours 57 minutes ago), you uploaded
a file with Spanish (es) translations for ddtp-ubuntu-main in Package
Descriptions for Ubuntu ubuntu to Launchpad.

We were unable to import the file because of errors in its format:

Line 17560: String not terminated

...http://launchpadlibrarian.net/16686992/es.po

I check the line, but everithing is OK. I can image what is the problem.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Jeroen T. Vermeulen
Solved:
2008-08-16
Last query:
2008-08-16
Last reply:
2008-08-13
Best Jeroen T. Vermeulen (jtv) said : #1

This sometimes happens when there's a Windows-style line ending (carriage return + line feed). Sometimes a carriage return ends up inside the quotes. Then if you run it through msgfmt on a Unix-like system, it's more or less ignored and there's no problem. But Launchpad sees it as a line ending before the quote, and complains about an unterminated string.

Try removing the last bit of that line (the last character of the string, and the closing quote) and re-typing them. That should also get rid of the carriage return.

Paco Molinero (franciscomol) said : #2

Thanks Jeroen T. Vermeulen, that solved my question.