Mirrored branch gives LP an AssertionError

Asked by Mark Lee

My mirrored branch <https://code.edge.launchpad.net/~malept/bzr-gentoo-overlay/overlay-main> is showing the following error:

> This branch may be out of date, as Launchpad has not been able to access between 2008-06-30 and 9 hours ago.
> (AssertionError: <bzrlib.bzrdir.BzrDirMeta1 object at 0x95bee4c> is not a RemoteBzrDir) Launchpad will try again shortly.

Googling for the error reveals that it might have been discussed in #launchpad - <http://irclogs.ubuntu.com/2008/07/09/%23launchpad.html>, which I think references <http://irclogs.ubuntu.com/2008/07/07/%23launchpad.html>. Might there be a problem with mirroring bzr+http branches? FWIW, I can branch from it just fine using bzr-1.6b3 on my local machine.

Bazaar branch information:
In a repository initialized with --no-trees; utilizes a WSGI-based smart server (via FastCGI); branch format is pack-0.92. Server runs bzr 1.3.1 on Python 2.4.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Jonathan Lange
Last query:
Last reply:
Revision history for this message
Best Jonathan Lange (jml) said :

Hi Mark,

You are right: Launchpad can't mirror bzr+http branches at the moment. It's something that we are looking to fix real soon now (basically we're waiting for the next release of Bazaar).

We're tracking this on bug #245918, which I've linked to this question.

Hope this helps,

Revision history for this message
Mark Lee (malept) said :

Thanks Jonathan Lange, that solved my question.