PPA - configure: error: C compiler cannot create executables for feisty & dapper, hardy & gusty OK

Asked by Jeffrey Ratcliffe on 2008-05-28

For feisty and dapper, gtkimageview FBTFS in my PPA (https://launchpad.net/~jeffreyratcliffe/+archive), not configuring:

chmod a+x /build/buildd/gtkimageview-1.6.1/./configure
cd . && CC="cc" CXX="g++" CFLAGS="-g -Wall -O2 -fgnu89-inline" CXXFLAGS="-g -Wall -O2" CPPFLAGS="" LDFLAGS="" /build/buildd/gtkimageview-1.6.1/./configure --build=x86_64-linux-gnu --prefix=/usr --includedir="\${prefix}/include" --mandir="\${prefix}/share/man" --infodir="\${prefix}/share/info" --sysconfdir=/etc --localstatedir=/var --libexecdir="\${prefix}/lib/gtkimageview" --disable-maintainer-mode --disable-dependency-tracking --srcdir=. --disable-static
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for gcc... cc
checking for C compiler default output file name...
configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [config.status] Error 77

The identical package builds in Gutsy and Hardy OK.

Where can I read the config.log?

The configure error message normally means that build-essentials is not properly installed.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Bienia
Solved:
2008-06-05
Last query:
2008-06-05
Last reply:
2008-06-04
Diogo Matsubara (matsubara) said : #1

After asking Celso, this bug report is better handled as a question.

Celso Providelo (cprov) said : #2

Exactly, this is a packaging issue, not a soyuz bug. I will point it to a MOTU developer, but feel free to seek help yourself in #ubuntu-motu.

I did, but no one answered it - and as the information to debug the problem was not available, I figured it was anyway a bug.

Best Michael Bienia (geser) said : #4

First, I can reproduce the FTBFS in my feisty pbuilder.
And the config.log contains the reason for it:

gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
configure:2757: $? = 0
configure:2764: cc -V >&5
cc: '-V' option must have argument
configure:2767: $? = 1
configure:2790: checking for C compiler default output file name
configure:2817: cc -g -Wall -O2 -fgnu89-inline conftest.c >&5
cc1: error: unrecognized command line option "-fgnu89-inline"
configure:2820: $? = 1

After commenting out line 9 (CFLAGS) in debian/rules, the package builds.

Thanks Michael Bienia, that solved my question.