Can't use email interface

Asked by Iain Lane on 2008-06-03

Whenever I try to use the email interface (for new bugs, replying to bugs or editing old bugs), nothing happens. Nothing at all - I don't get an error message or anything.

I've tried using two different email addresses (and SMTP servers) which are associated with my account. Emails have been signed with the GPG key registered to the account, although if I forget to do this, I get no error message in reply as the wiki says I should.

Is this something going on at my end?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Eleanor Berger Edit question
Solved by:
Iain Lane
Solved:
2008-07-31
Last query:
2008-07-31
Last reply:
2008-07-31
Diogo Matsubara (matsubara) said : #1

Hi Iain,

can you point me one of the bugs you tried to edit using the email interface? Can you paste <http://pastebin.ubuntu.com/> the emails you sent through the email interface?

Also, make sure your ISP is not filtering the replies from Launchpad as spam.

Thanks,

Matsubara

Iain Lane (laney) said : #2

Hi Matsubara, Thanks for taking the time to help me.

Here's two examples of replies I tried to send, both of which silently failed: http://pastebin.ubuntu.com/16648/

They were both GPG signed, but I can't copy and paste this because Thunderbird hides it.

Nothing relevant is in the spam box.

Thanks

Diogo Matsubara (matsubara) said : #3

Hi Iain,

I just tried to modifiy a bug report using the email interface and it worked for me. I couldn't find anything wrong in the email interface logs.

Would you try sending those emails again, including me <email address hidden> in the CC list?

Thanks, Matsubara

Iain Lane (laney) said : #4

Hello,

I've just sent one and CCed you as requested. Unmarking this question as "Answered" until we know it's fixed.

Thanks.

Diogo Matsubara (matsubara) said : #5

Hi Iain,

got your email and it's not gpg signed. You should get a reply with subject "Submit request failure" or something like that, explaining that you need to gpg sign emails sent via the email interface.

Did you get such reply from Launchpad?

Thanks.

Iain Lane (laney) said : #6

Hi, sorry about that. I sent two identical emails (one signed and one not - the intention of this was to provoke the error message), but received nothing in reply, not even the error that you indicated I should have got. I inadvertently forgot to cc you in the first one which was signed, screenshot at [1]. If you want me to do it again and CC you then I will.

[1] http://orangesquash.org.uk/~laney/email

Iain Lane (laney) said : #7

(FYI, I added the comment that you can see on the bug through the web interface)

Diogo Matsubara (matsubara) said : #8

Hi Iain,

are you checking your launchpad@orange email address? You sent me an email from iain@orange but if any error occurred, Launchpad would reply to your preferred address, which is launchpad@orange.

Can you check if the replies are going there? Or any of your other registered emails.

Thanks

Diogo Matsubara (matsubara) said : #9

Sorry, clicked the wrong button. I was asking for more info, not giving an answer.

Iain Lane (laney) said : #10

Yes. That forwards to the same inbox.

Iain Lane (laney) said : #11

I removed SPF on my domain to see if it was failing on that, but no change.

Iain,

Can you get the help text for the email interface by sending an email to <email address hidden> ?

I'd like to find out because that can help determine how far you can get communicating with the email interface.

Iain Lane (laney) said : #13

I sent a blank email to <email address hidden> and have gotten no reply.

Thanks for your help

Christian Reis (kiko) said : #14

How are you replying to these questions? Via email or using the web UI?
If you are using the Web UI, can you try replying via email?
--
Christian Robottom Reis | http://async.com.br/~kiko/ | [+55 16] 3376 0125

Iain Lane (laney) said : #15

Doesn't seem to have appeared. Here's the message I sent:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Christian Reis wrote:
> Your question #35165 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/35165
>
> Status: Open => Answered
>
> Christian Reis proposed the following answer:
> How are you replying to these questions? Via email or using the web UI?
> If you are using the Web UI, can you try replying via email?

I was using the Web UI. If this works then emailing questions is OK!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFITtS9Py0SnCC/zccRAonLAKCKFkMpXB0J2j0Uh0EKAVg8Zj2q5QCeIkvH
1zjNeStAwbHmLj160mr0ZGI=
=4baH
-----END PGP SIGNATURE-----

Christian Reis (kiko) said : #16

On Tue, Jun 10, 2008 at 07:53:10PM -0000, Iain Lane wrote:
> Doesn't seem to have appeared. Here's the message I sent:

OK. Can you send me a message with full headers so I can forward that to
our IS department?
--
Christian Robottom Reis | http://async.com.br/~kiko/ | [+55 16] 3376 0125

Iain Lane (laney) said : #17

Sent you one, to the address on your LP profile. Thanks!

Rui Boon (ruiboon) said : #18

Hi. I am also experiencing this problem of not being able to use the email interface to comment bug reports. There is no failure message from launchpad. Both GPG signed and non signed messages do not seem to go through. Spam folder is clean. Not sure if this helps, but i am currently using edge.

I have attached my email with full headers in http://paste.ubuntu.com/19534/

Iain Lane (laney) said : #19

Ah yes, I forgot to say that. I'm using edge too.

Launchpad Janitor (janitor) said : #20

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Iain Lane (laney) said : #21

Reopening

Launchpad Janitor (janitor) said : #22

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

We still need to answer this, so no need to expire the question yet.

Iain Lane (laney) said : #24

Hi Tom,

Do you have any more information on this?

Thanks for looking into it for me.

Launchpad Janitor (janitor) said : #25

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Christian Reis (kiko) said : #26

Still happening, right?

Iain Lane (laney) said : #27

On Thu, Jul 31, 2008 at 06:41:55AM -0000, Christian Reis wrote:
> Your question #35165 on Launchpad itself changed:
> https://answers.edge.launchpad.net/launchpad/+question/35165
>
> Status: Expired => Open
>
> Christian Reis changed the question status:
> Still happening, right?
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

I'm just testing. If this message appears then I can send email messages
using mutt on my server, and will try from my client at home later.

Rui Boon (ruiboon) said : #28

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Christian Reis wrote:
| Question #35165 on Launchpad itself changed:
| https://answers.edge.launchpad.net/launchpad/+question/35165
|
| Status: Expired => Open
|
| Christian Reis changed the question status:
| Still happening, right?
|
Here's another attempt in trying to use the email interface to reply....
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFIkce4zjrqiOSXNeMRAlaQAJ0eDqHcJJj6PAepsFsRR4YGM//0VwCcDYHc
gMwlsgfMDcTQKitOTCu/aRE=
=zZIu
-----END PGP SIGNATURE-----

Iain Lane (laney) said : #29

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Rui Boon wrote:
> Your question #35165 on Launchpad itself changed:
> https://answers.launchpad.net/launchpad/+question/35165
>
> Status: Open => Answered
>
> Rui Boon proposed the following answer:
> Christian Reis wrote:
> | Question #35165 on Launchpad itself changed:
> | https://answers.edge.launchpad.net/launchpad/+question/35165
> |
> | Status: Expired => Open
> |
> | Christian Reis changed the question status:
> | Still happening, right?
> |
> Here's another attempt in trying to use the email interface to reply....

Testing from Thunderbird
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIkfmRPy0SnCC/zccRAtN5AJ0e2fX/0kq7DVB52VdosXkXZ72hpwCgsWai
YzLDeKMsBVQ+VJpUeGz8+ZY=
=210U
-----END PGP SIGNATURE-----

Iain Lane (laney) said : #30

Seems fixed now. Don't know if you guys changed anything, but thanks for the help. :)