PPA missing dependency

Asked by Jeffrey Ratcliffe on 2008-05-12

I am trying to build gtkimageview, and its Perl bindings, libgtk2-imageview-perl:

https://launchpad.net/~jeffreyratcliffe/+archive

Both build fine in intrepid and hardy, and gtkimageview builds fine in gutsy, but libgtk2-imageview-perl FTBFS in gutsy, missing libgtkimageview-dev, which was provided by gtkimageview.

I have tried rebuilding libgtk2-imageview-perl without success

What is going on?

Best Celso Providelo (cprov) said : #1

Hi Jefrey,

libgtk2-imageview-perl FTBFS in gutsy because there is no libgtkimageview-dev package in gutsy. I've copied the source from hardy but the rebuilt binaries could not be published.

This was mainly caused by a defect in the current copy-ui algorithm, it should not allow you to copy source-only inside the same archive if it has already built binaries.

To fix the problem you can copy the hardy version of gtkimageview - 1.6.1-2 source and its binaries to gutsy and retry the perl-binding build. Let me know if it makes sense.

Also, be careful with the misleading information about intrepid builds, they are not OK, in fact, intrepid is not open for PPAs and builds were not created for it.

Thanks for your comments. In the end, I bumped the version number to upload a Gutsy gtkimageview package, and after that had built, a simple rebuild for the Perl bindings worked fine.