Can't upload source package to ppa

Asked by MapleZhou

 I've tried uploading a source package, and it gets rejected with the following error.

Unable to find distroseries: unstable
Further error processing not possible because of a critical previous error.

Hash: SHA1

Format: 1.7
Date: Fri, 11 Apr 2008 16:14:53 +0800
Source: fivedash
Binary: fivedash
Architecture: source all
Version: 0.7-2
Distribution: unstable
Urgency: low
Maintainer: Maple Zhou <email address hidden>
Changed-By: Maple Zhou (programer) <email address hidden>
 fivedash - General purpose accounting for small business
 fivedash (0.7-2) unstable; urgency=low
  * Initial release (Closes: #nnnn) <nnnn is the bug number of your ITP>
 35b11f21dbc2e0e22ecafe1ee90710d9 572 web optional fivedash_0.7-2.dsc
 6e32748b18040212d31f4bdc04c6cd56 5996 web optional fivedash_0.7-2.diff.gz
 e1035d1afd68dc1015bcb40085c4810c 420838 web optional fivedash_0.7-2_all.deb

Version: GnuPG v1.4.6 (GNU/Linux)


If you don't understand why your files were rejected, or if the
override file requires editing, reply to this email.

I repied this email, however,I geted the following email from <email address hidden>

This is an automatically generated Delivery Status Notification

Delivery to the following recipient failed permanently:

    <email address hidden>

Technical details of permanent failure:
PERM_FAILURE: Gmail tried to deliver your message, but it was rejected by the recipient domain. The error that the other server returned was: 550 550 <email address hidden>: Recipient address rejected: User unknown in virtual alias table. We recommend contacting the other email provider for further information about the cause of this error. Thanks for your continued support. (state 14)

  ----- Original message -----

Received: by with SMTP id n5mr104596bue.84.1207912258596;
       Fri, 11 Apr 2008 04:10:58 -0700 (PDT)
Received: by with HTTP; Fri, 11 Apr 2008 04:10:58 -0700 (PDT)
Message-ID: <email address hidden>
Date: Fri, 11 Apr 2008 19:10:58 +0800
From: "binbin zhou" <email address hidden>
To: "Launchpad PPA" <email address hidden>
Subject: Re: fivedash_0.7-2_i386.changes rejected
In-Reply-To: <-2229702910455983532@unknownmsgid>
MIME-Version: 1.0
Content-Type: multipart/alternative;
References: <-2229702910455983532@unknownmsgid>

Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

Why did Lauchpad reject my source package?

2008/4/11, Launchpad PPA <email address hidden>:
> Rejected:

  ----- Message truncated -----

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Julian Edwards
Last query:
Last reply:
Revision history for this message
Best Julian Edwards (julian-edwards) said :

Distribution: unstable

This is not valid. It should be "gutsy" or "hardy" etc.

In addition, you are uploading binaries mixed with your source, that will also fail once you fix the Distribution header.

Revision history for this message
MapleZhou (maplezhou110) said :

I had fixed the Distribution header, however I can't update the *.orig.tar.gz file(the .change file didn't include this file).

Revision history for this message
MapleZhou (maplezhou110) said :

Thanks Julian Edwards, that solved my question.

Revision history for this message
olmec (olmecs) said :

I modified my changes file prior to running debuild. But I got the same rejection:

Unable to find distroseries: unstable

Any ideas?

Revision history for this message
Curtis Hovey (sinzui) said :

Hi olmec, You should ask your own question instead of interjecting into another conversation. The build system is expecting the code name of an Ubuntu series. There are listed here
The unstable series is has the status "development".