Import queue statuses explanation

Asked by Kamil Páral

I haven't found any explanation of import queue statuses anywhere. Could you point me somewhere?

I would be particularly interested in what "blocked" and "needs review" means. I have uploaded translation of synaptic, which is now "blocked". So what can I do about it? Wait, delete it, try again? How can I know? And when I switch it to "needs review", does it mean rosetta sends me some explanation of what's going on? Or it will wait for review from rosetta administrators? Hard to say.

Using import queue is similar to crossing 4-way motorway while being blind, sorry to say that :/ Can somebody help me? And could you add some legend (or at least tooltips) to import queue page? Thanks.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Kamil Páral
Last query:
Last reply:
Revision history for this message
Jeroen T. Vermeulen (jtv) said :

We don't have any documentation of this online as far as I know, but in brief: "Needs review" means that a file is held until it is either approved automatically, or manually by one of us. "Blocked" means that an upload should not be imported, whether in its current form or in future revisions. If a template is blocked, its translations will also be blocked.

Generally the only reason why you should need to change a request's status is to delete it, either because its import failed or because you no longer want it imported.

Revision history for this message
Kamil Páral (kamil.paral) said :

Ok, thank you. But if the import fail, an explanation is sent to me via email, so I can repair problems. How can I find out the reason, when import is blocked? I did not get any explanation email that time. I would like to know why it is blocked, so I can do something about it.

I have recently tried to import translation of synaptic in "cs" language and my import got blocked. After few days Martin Böhm tried to import *exactly the same* file, and it got approved. You can see it here, at least at the moment:
Can you tell me what I am doing wrong?

Revision history for this message
Jeroen T. Vermeulen (jtv) said :

That does sound like the upload was blocked by mistake. There is a blocked template in the same package, but it's not the one you're translating. I've asked one of my colleagues to look into it, and he concurred.

Revision history for this message
Kamil Páral (kamil.paral) said :

Thank you, it has been imported now. I hope we managed to catch the today's translation deadline for hardy :)

Revision history for this message
helix84 (helix84) said :

Hello, this same thing just happened to me. I'll ask for another import of the same file.

po/sk.po in synaptic in Ubuntu Jaunty Blocked
Uploaded by Pavol Klačanský on 2009-03-09 13:04:26 CET
Will be imported into Slovak (sk) translation of synaptic in Ubuntu Jaunty package "synaptic"