My PPA package uploads are not showing up

Asked by Michal Migurski

I am attempting to upload a test package to this PPA:

This is my first time experimenting with building Debian packages or writing to PPAs.

My local package has been signed using `debuild -k'8CBDE645' -S`, then I run `dput ppa:migurski/hello hellodeb_0.1_source.changes`. I see output like “Uploading to ppa (via ftp to”, and then the file `hellodeb_0.1_source.ppa.upload` is created with the following content:

    Successfully uploaded hellodeb_0.1.dsc to for ppa.
    Successfully uploaded hellodeb_0.1.tar.gz to for ppa.
    Successfully uploaded hellodeb_0.1_source.changes to for ppa.

I expected to see the test package on the PPA page above, but instead see “This PPA does not contain any packages yet.”

Question information

Chinese (Simplified) Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Michal Migurski
Last query:
Last reply:
Revision history for this message
Colin Watson (cjwatson) said :

Our logs say that we sent you an automatic rejection email which should have looked roughly like this:

  From: Launchpad PPA <email address hidden>
  To: migurski <email address hidden>
  Subject: [~migurski/ubuntu/hello] hellodeb_0.1_source.changes (Rejected)

  migurski: no @ found in email address part.
  Unable to identify 'Michal Migurski':<migurski@test-ppa> in launchpad
  Further error processing not possible because of a critical previous error.

  hellodeb (0.1) trusty; urgency=medium

    * Initial release. (Closes: #XXXXXX)


  If you don't understand why your files were rejected please send an email
  to <email address hidden> for help (requires membership).

  You are receiving this email because you made this upload.

In other words, the email address you used in the top entry in debian/changelog was badly malformed. Firstly, the quoting and colon and such in there is weird and so it failed to parse as an email address; secondly, migurski@test-ppa is not a real email address and so it would have been rejected after that point anyway. You need to make sure that the email address is written in a valid way and associated with your Launchpad account. So you probably want the last line of the top changelog entry to look something like this:

 -- Michal Migurski <email address hidden> Sat, 09 Apr 2016 17:57:50 +0100

The "dch" program can help you with getting this right, as long as you set DEBFULLNAME and DEBEMAIL properly in the environment (for instance, I have DEBFULLNAME='Colin Watson' and <email address hidden>).

Revision history for this message
Michal Migurski (migurski) said :

Thank you, this is helpful. I’ve ensured that future mails to that address don’t wind up in spam, and I’ll search for where this email address was generated. `test-ppa` is the hostname for the machine where I’m working on this.

Revision history for this message
Michal Migurski (migurski) said :

I’m continuing to see related errors after fixing the email address. Previously, I was using this dch command: `dch --create -v 0.1 --package hellodeb`. After reading the docs I found the DEBEMAIL setting and changed it to this: `env <email address hidden> dch --create -v 0.1 --package hellodeb`

This is the content of my debian/changelog file:

    hellodeb (0.1) trusty; urgency=medium

      * Initial release. (Closes: #XXXXXX)

     -- Michal Migurski <email address hidden> Sun, 17 Apr 2016 19:23:14 -0700

I’m still seeing the "no @ found in email address part" error via email, but since I’m using dch to generate these changelogs I am finding it difficult to diagnose the problem.

Revision history for this message
William Grant (wgrant) said :

That changelog looks fine now, so I suspect the Maintainer field in debian/control has a similar problem.

Revision history for this message
Michal Migurski (migurski) said :

Thank you William, changing that field helped me make progress.

I am now seeing a new error:

    hellodeb_0.1.dsc: Unknown section '-'
    hellodeb_0.1.tar.gz: Unknown section '-'
    Further error processing not possible because of a critical previous error.

In hellodeb_0.1.dsc, there are lines with dashes that delimit PGP message sections; it looks like this:

    Hash: SHA1

    Format: 1.0
    Source: hellodeb
    Binary: hellodeb
    Architecture: all
    Version: 0.1
    Maintainer: <email address hidden>
     hellodeb deb testing optional
     9377e145a483bb668551b71719cca62b07f343a7 782 hellodeb_0.1.tar.gz
     d76c33fbc9b7acf7bfea82a46125a36c22d700bafceaaa20cba7ee72514262e0 782 hellodeb_0.1.tar.gz
     1e6b1e28e8d415c2b01f28b0de14e3aa 782 hellodeb_0.1.tar.gz

    Version: GnuPG v1

    -----END PGP SIGNATURE-----

Revision history for this message
William Grant (wgrant) said :

Those OpenPGP section delimiters aren't the issue; you're probably missing Section fields in your debian/control file.

Revision history for this message
Michal Migurski (migurski) said :

I do have a `Section: testing` line in my control file; it looks like this (modified starting from a tutorial I am following, hence sonce of the weird URLs):

    Source: hellodeb
    Maintainer: <email address hidden>
    Priority: optional
    #Version: 0.1
    #Installed-Size: 6

    Package: hellodeb
    Architecture: all
    Depends: bash
    Section: testing
    Description: This is my first debian package.
     Guided by Totti Torvalds.
     In Description new line start with a space.

Revision history for this message
William Grant (wgrant) said :

Which tutorial are you following? Installed-Size and Version are fields from a binary package's DEBIAN/control file, not a source package debian/control. I'd suggest going through and

The specific problem that's causing your latest rejection, though, is that you need a Section field in the Source stanza too.

Revision history for this message
Michal Migurski (migurski) said :

ACCEPTED. Thank you William.

In your second link it says that Section fields are “recommended,” does Ubuntu have a “required” policy different from Debian’s? I have added a Section field to the first stanza. After I resubmitted I learned that “testing” is not a valid Section, and have changed it to “utils”.

So, the package now exists. I’m moving on to trying to get it installed, and `apt-add-repository ppa:migurski/hello` is telling me that the signing key fingerprint does not exist. Is that due to the delay described here?

Thanks again for your ongoing help with this. I have been following this tutorial from Ask Ubuntu:

I read a few other sources as well:


They were somewhat helpful as background information, but I was hoping to pass all the way through the process before going back to learn about each piece after I knew I was on the right track with a working, published, package.

Revision history for this message
Michal Migurski (migurski) said :

Waited a while, and the key became available. I appreciate your help, William and Colin.