uploading translations with different filenames

Asked by Jeff Fortin Tam on 2006-12-15

Specto used to have translations set up like this:
po/specto.pot
po/fr.po
po/fr.mo

However, the directory structure changed a bit, it is now like this:
po/specto.pot
po/fr/specto.po
po/fr/specto.mo

I *think* that rosetta refuses my uploads of specto.mo because they are the same as fr.po, maybe it's detecting a collision? Could this be fixed?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Carlos Perelló Marín Edit question
Solved by:
Carlos Perelló Marín
Solved:
2007-01-11
Last query:
2007-01-11
Last reply:
2007-01-04
Whiteboard:
Carlos, can you take a look at this request? -- matsubara
Jeff Fortin Tam (kiddo) said : #1

uh sorry, I meant specto.po (all the languages are now using a file called specto.po).

Jeff Fortin Tam (kiddo) said : #2

Hello? Can something be done with this, or do I un-rosetta my project and ask people to use poedit?

Hi,

That shouldn't be a reason to reject your import.

I don't see any specto file in the import queue neither as Needs review or Failed.

What's the error message you get and where do you get it? by email or in the web form?

Jeff Fortin Tam (kiddo) said : #4

Well I guess those po files must have timed out since then. I just tried uploading fr/specto.po, it/specto.po, de/specto.po one after another (https://translations.launchpad.net/translations/imports/+index?target=products&status=all&type=po&start=0&batch=300)

thing is, since they all have the same filename, rosetta just assumed they were the same too, and there is only one item in the import queue. I haven't thought about that too.

Since the last time when I tried uploading those lang files, the translations progress bars have not changed (specto is fully translated in italian, french, german, swedish).

I don't know if that single file will pass through the import queue, last time I checked it was most likely rejected without an error or notification (because the progress bars have not changed).

The path matters, so it should not be imported in the same entry.

Would you give me more details?

URL where you are doing the upload, whether you upload single files by hand or using a tar.gz (and a link to the files) so I can try to reproduce the upload and debug it better.

Thank you.

Jeff Fortin Tam (kiddo) said : #6

I am starting on this page: https://translations.launchpad.net/specto/0.2/+pots/specto which leads me to upload using this page: https://translations.launchpad.net/specto/0.2/+pots/specto/+upload

I am uploading manually every po and pot files in this trunk: http://specto.googlecode.com/svn/trunk/po/

Hope this helps!

Ok, so the problem I see (I will need that you confirm it) is that you are uploading file by file one after the other.

That makes impossible to us to know whether is a translation, a template or what's it because the path information is lost.

The best solution is just to prepare a tar.gz with all your files in the right paths and Rosetta will know where to put them.

Another option is to use the language specific URL depending on the .po file you are uploading. For instance, for French translations:

https://translations.launchpad.net/specto/0.2/+pots/specto/fr/+upload

If you are already uploading a tarball, please, reopen the ticket.

Jeff Fortin Tam (kiddo) said : #8

User confirmed that the request is solved.